xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 5 years ago

Closed 5 years ago

Last modified 5 weeks ago

#1023 closed defect (duplicate)

Mac OS X: dyld: Library not loaded: libgstreamer.dylib

Reported by: Timothy Basanov Owned by: Antoine Martin
Priority: critical Milestone:
Component: core Version: 0.14.x
Keywords: Cc:

Description

Could not start Xpra on a Mac. Reproduces on at least one more Mac nearby.
I've been using manually compiled Xpra for quite some time.
Today I've tried to use Xpra.dmg and it does not start.

I can confirm that when I download Xpra.dmg (verified versions 0.14.18, 0.14.29 and 0.14.head) and
try to run Xpra from the binary directory from the command line I see errors on OS X 10.11.1 (15B42).

Here is an example of an output:

$ ~/Applications/Xpra.app/Contents/MacOS/Xpra attach ssh:timothy:100
** (Xpra:13573): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'
** (Xpra:13573): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'
** (Xpra:13573): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
2015-11-04 16:24:38,494 xpra client version 0.14.18
dyld: Library not loaded: /Users/MacAdmin/gtk/inst/lib/libgstreamer-0.10.0.dylib
  Referenced from: /Users/timofeyb/Applications/Xpra.app/Contents/Helpers/gst-plugin-scanner
  Reason: image not found

At this point it hangs and could not be killed by C.

At the same time manually built version works (as of version 0.14.29).

Change History (2)

comment:1 Changed 5 years ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #984.

comment:2 Changed 5 weeks ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1023

Note: See TracTickets for help on using tickets.