xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1031 closed defect (fixed)

0.15.8: complains about invalid config

Reported by: onlyjob Owned by: onlyjob
Priority: critical Milestone: 0.16
Component: core Version: 0.15.x
Keywords: Cc:

Description

Attempt to start Xpra-0.15.8 built from source as xpra start :33 fails with the following in /home/user/.xpra/:33.log:

Parse error on line 104 of section InputClass in file /home/user/.xpra/xpra.conf
        "p<BF>v<88>3V" is not a valid keyword in this section.

It complains on every uncommented line. If I comment a particular line it stops on next uncommented one with the similar error.
This is a regression as 0.15.6 (and earlier versions) did not have such problem.

Change History (5)

comment:1 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob
  • Parse error on line.. is not from xpra
  • since you use a specific /home/user/.xpra/xpra.conf, it would be helpful to include it


This is a regression as 0.15.6 (and earlier versions) did not have such problem.


I very much doubt that is the case.
My bet is a syntax error on your side.

comment:2 Changed 3 years ago by onlyjob

Component: androidcore
Owner: changed from onlyjob to Antoine Martin
Version: trunk0.15.x

No, it is not a syntax error as 0.15.6 works. No, it is not useful to include config because 0.15.8 stops on every un-commented line -- just copy /etc/xpra/xpra.conf as /home/user/.xpra/xpra.conf and make sure that any like keyboard-sync = no or speaker or encoding is set.

Do you think that after all those years of maintaining Xpra I would not recognise a syntax error?

comment:3 Changed 3 years ago by Antoine Martin

Status: newassigned

Caused by r11013, undoing this change should get you going.
FYI: this is Xorg moaning, not xpra.

comment:4 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob
Status: assignednew

Should be fixed in r11218 using a directory that should not exist by default named xorg.conf.d (changed from xorgconfdir in r11222), or if it does exist it should be clear that it is for xorg config files only (which is not a bad thing to have in any case, so users can customize their config more easily).

Applied to v0.15.x in r11219, v0.14.x in r11221.

@onlyjob: please confirm and close.

comment:5 Changed 3 years ago by onlyjob

Resolution: fixed
Status: newclosed

All good with r11219, thanks.

Note: See TracTickets for help on using tickets.