xpra icon
Bug tracker and wiki

Changes between Initial Version and Version 3 of Ticket #1036


Ignore:
Timestamp:
11/18/15 16:17:09 (5 years ago)
Author:
Antoine Martin
Comment:

(also editing the ticket description)

Here is the (long) original thread which came before this ticket: http://lists.devloop.org.uk/pipermail/shifter-users/2015-November/001399.html.

FYI: this should be equivalent to the commands you used and both easier to understand and harder to get wrong:

XPRA_RANDR=0 xpra start \
    --xvfb="Xvfb :99 -screen 0 3840x2160x24+32 -fbdir /var/tmp" \
    --sync-xvfb=50 --bind-tcp=127.0.0.1:10000 \
    --start=libreoffice

Why libreoffice? I test with an xterm which is a LOT easier to handle.

Then there's this:

  • opengl=no - why? (part of the problem)
  • encoding=jpeg - why?
  • quality=85 - why?
  • z9 - why? (a very bad idea it is too)

I eventually found a bug, caused by the changes in #976, which only occurs with opengl disabled and with downscaling (desktop-scaling<1.0), fixed in r11288.

You can find beta packages for Ubuntu Trusty here: http://xpra.org/beta/trusty/.

@zenny: please close if this ticket if that works for you.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1036

    • Property Cc garbytrash@… added
    • Property Owner changed from Antoine Martin to zenny
  • Ticket #1036 – Description

    initial v3  
    1 I am on  trying to run server's virtual X at 4K and the client's in Full HD or lower. Everthing works alright (thanks to Antoine for useful inputs) except only 1/4 of the client screen refreshes, leaving 3/4 from the previous screen.
     1I am trying to run server's virtual X at 4K and the client's in Full HD or lower. Everything works allright (thanks to Antoine for useful inputs) except only 1/4 of the client screen refreshes, leaving 3/4 from the previous screen.
    22
    33However if I manually switch to and fro from the workspace (pager) running the client xpra instance, it gets refreshed.
     
    88
    99SERVERSIDE:
    10 $ Xvfb :99 -screen 0 3840x2160x24+32 -fbdir /var/tmp &
    11 $ XPRA_RANDR=0 xpra start --use-display :10 --sync-xvfb=50 --bind-tcp=localhost:10000 &
    12 $ export DISPLAY=:10
    13 $ libreoffice &
     10{{{
     11Xvfb :10 -screen 0 3840x2160x24+32 -fbdir /var/tmp &
     12XPRA_RANDR=0 xpra start --use-display :10 --sync-xvfb=50 --bind-tcp=localhost:10000 &
     13export DISPLAY=:10
     14libreoffice &
     15}}}
    1416
    1517CLIENTSIDE:
    16 $ xpra attach tcp:localhost:10000:10 --desktop-scaling=0.5 --opengl=no --encoding=jpeg --quality=85 -z9
     18{{{
     19xpra attach tcp:localhost:10000:10 --desktop-scaling=0.5 --opengl=no --encoding=jpeg --quality=85 -z9
     20}}}
    1721
    1822Please find attached screenshot of the refreshed window.