xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#1045 closed defect (fixed)

HTML5 Client Intro page loops

Reported by: zenny Owned by: zenny
Priority: major Milestone: 0.16
Component: html5 Version: trunk
Keywords: loop html5 xpra client Cc:

Description

Have run xpra server (ref: http://xpra.org/trac/wiki/Clients/HTML5) with:

XPRA_RANDR=0 xpra start :10 \
    --xvfb="Xorg -noreset -nolisten tcp +extension GLX \
    -config /etc/xpra/xorg.conf \
    +extension RANDR +extension RENDER \
    -logfile ${HOME}/.xpra/Xorg-10.log" \
    --sync-xvfb=50  --sharing=yes \
    --bind-tcp=localhost:10000 --html=on \
    --start=libreoffice


Accessing http://localhost:10000 gives me the same default form page in loop instead of the running libreoffcie even after I filled the form many a times as in the attached screenshot.


Websockify is installed:

$ dpkg -l | grep ii | grep websockify
ii  websockify                                 0.5.1+dfsg1-3ubuntu0.14.04.1                                amd64        WebSockets support for any application/server


All ports are open in the server.

Attachments (1)

2015-12-01--1448962562_1152x526_drbista@gmail.png (35.5 KB) - added by zenny 5 years ago.
xpra html5 client loops to the same intro page.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by zenny

xpra html5 client loops to the same intro page.

comment:1 Changed 5 years ago by Antoine Martin

Owner: changed from Josh to zenny

The problem is immediately obvious from the server log file, this should be fixed in r11343.
You can also use a stable 0.15.x version, which does not have this problem.

Warning: localhost is not a valid IP address and should not be used, the server does give you a warning about this in the log file. It only works by accident because the safe fallback is "127.0.0.1".

BTW, none of these things are relevant to this ticket and only make things more complicated than they need to be:

  • XPRA_RANDR
  • xvfb
  • sync-xvfb
  • sharing
  • libreoffice

You can reproduce the problem with just:

xpra start :10 --bind-tcp=127.0.0.1:10000 --html=on --start=xterm
xdg-open http://127.0.0.1:1000/
Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 5 years ago by zenny


You can also use a stable 0.15.x version, which does not have this problem.

Thank you for the pointer, but I cannot roll back to 0.15.x because I need some features available only in 0.16 beta.


Warning: localhost is not a valid IP address and should not be used,


I didn't use localhost, but the IP of the xpra server which you can see in the attached screenshot (http://192.168.10.3:10000)

The problem is immediately obvious from the server log file, this should be fixed in r11343.


Yep, I shall try with that patch.

Last edited 5 years ago by zenny (previous) (diff)

comment:3 Changed 5 years ago by Antoine Martin

I didn't use localhost, ..


Your command line definitely does.
See your own ticket description.

comment:4 Changed 5 years ago by zenny

Your command line definitely does.

But the IP address of the server has been replaced by localhost to make things at par with the documentation. But the screenshot attached to that ticket does not.

Anyway, there is nothing to argue as you already pointed out that should be fixed in r11343. Thanks for the pointer.

comment:5 Changed 5 years ago by Antoine Martin

But the IP address of the server has been replaced by localhost to make things at par with the documentation.


That does not make any sense: there is nothing anywhere on the wiki with localhost used with the "bind-tcp" option, as this would be invalid.

The only 2 hits when you search for "bind-tcp=localhost" are your own tickets.


But the screenshot attached to that ticket does not.


The screenshot shows the browser (and browsers obviously handle DNS names), not the "bind-tcp" option which is an xpra command line.

comment:6 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

I assume this is fixed. Closing.

Note: See TracTickets for help on using tickets.