xpra icon
Bug tracker and wiki

#1069 closed task (fixed)

switch to gstreamer 1.6.x on osx

Reported by: Antoine Martin Owned by: alas
Priority: blocker Milestone: 0.17
Component: platforms Version: trunk
Keywords: osx sound Cc:

Description

As can be seen here: http://gstreamer.freedesktop.org/src/gstreamer/, the 1.4.x branch has been abandoned over a year ago.
We should switch to the currently supported stable branch.

Change History (4)

comment:1 Changed 19 months ago by Antoine Martin

Priority: minorcritical

Please include details of what breaks with this change so we can try to fix it.
Sticking with the 1.4 branch is causing problems (see r12249), and even the 1.6 branch is no longer supported as 1.8 is out: https://gstreamer.freedesktop.org/releases/gstreamer/1.8.0.html.

comment:2 Changed 18 months ago by Antoine Martin

Priority: criticalblocker

Couldn't wait any longer for 0.17, so done in r12390.

I hit this trivial bug in gst-plugins-good-1.0:

(...)
In file included from gstosxcoreaudio.c:35:
gstosxcoreaudiohal.c: In function '_audio_system_get_default_device':
gstosxcoreaudiohal.c:62: warning: ISO C90 forbids mixed declarations and code
gstosxcoreaudiohal.c: In function '_audio_device_is_alive':
gstosxcoreaudiohal.c:126: warning: ISO C90 forbids mixed declarations and code
gstosxcoreaudiohal.c: In function '_audio_device_get_name':
gstosxcoreaudiohal.c:272: warning: ISO C90 forbids mixed declarations and code
gstosxcoreaudio.c: In function 'gst_core_audio_asbd_to_caps':
gstosxcoreaudio.c:419: error: 'kLinearPCMFormatFlagsSampleFractionMask' undeclared (first use in this function)
gstosxcoreaudio.c:419: error: (Each undeclared identifier is reported only once
gstosxcoreaudio.c:419: error: for each function it appears in.)
make[3]: *** [libgstosxaudio_la-gstosxcoreaudio.lo] Error 1

Fixed by patching the source file with:

#ifndef kLinearPCMFormatFlagsSampleFractionShift
#define kLinearPCMFormatFlagsSampleFractionShift 7
#endif
#ifndef kLinearPCMFormatFlagsSampleFractionMask
#define kLinearPCMFormatFlagsSampleFractionMask (0x3F << kLinearPCMFormatFlagsSampleFractionShift)
#endif

@smo: Is this the error you encountered? Please always record them. If so, please just merge this as a patch to the moduleset and re-assign to afarr for sound testing. I don't expect major regressions by switching from gstreamer 1.4.x to 1.6.x, but who knows.
(briefly tested with opus and mp3)

We should switch to 1.8 for 0.18: see #1168.

Last edited 18 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 18 months ago by Smo

Owner: changed from Smo to alas

I had the same error and created a patch r12528

forced a recompile by removing the source directory and doing

jhbuild buildone --force gst-plugins-good-1.0

Built successfully now needs to be tested.

comment:4 Changed 18 months ago by alas

Resolution: fixed
Status: newclosed

Installed and tested osx 0.17.0 r12465 client (from /beta repo) against 0.17.1 r12453 fedora 23 server (Session Info confirms GStreamer 1.6.4.0).

Sound is good quality, av-sync seems to be within .1 s (at the very outside... looks perfect to my ears).

Disconnecting/reconnecting; pausing/unpausing sound sources; using the application menu to turn speakers off/on; no problems to be found.

Sounds fixed to me. I'll take the liberty of closing.

Note: See TracTickets for help on using tickets.