xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1076 closed defect (fixed)

0.16.1 builds not finding python.version

Reported by: alas Owned by: alas
Priority: major Milestone: 0.17
Component: server Version: 0.16.x
Keywords: Cc:

Description

Trying to test the osx printing reversion to use .ps files (#995), I'm getting the following error on both server (my 0.16.1 r11596 fedora 23 build and maxmylyn's both) and client (the 0.16.1 r11593 osx build in your beta repo).

2016-01-05 11:20:25,937 Error: failed to query sound subsystem:
2016-01-05 11:20:25,937  python.version not found in sound properties

Needless to say, there is no working sound. When I tried the 0.16.1 osx client against the 0.16.1 fedora 23 server, I also got a huge stream of the following traceback (come to think of it, I think calvin mentioned that you had forgotten to delete the "frozen" variable in the code that I think you merged for the #835 traceback issue):

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1025, in expire_delayed_region
    self.may_send_delayed()
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1124, in may_send_delayed
    self.do_send_delayed()
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1136, in do_send_delayed
    self.send_delayed_regions(*delayed)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1151, in send_delayed_regions
    self.do_send_delayed_regions(damage_time, window, regions, coding, options)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_video_source.py", line 581, in do_send_delayed_regions
    self.process_damage_region(damage_time, window, actual_vr.x, actual_vr.y, actual_vr.width, actual_vr.height, coding, video_options, 0)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_video_source.py", line 621, in process_damage_region
    WindowSource.process_damage_region(self, damage_time, window, x+w-dw, y, dw, h, self.edge_encoding, options, flush=1)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1309, in process_damage_region
    avsynclog("scheduling encode queue iteration in %ims, pixels frozen=%s, encode queue size=%i (max=%i)", av_delay, frozen, l, self.encode_queue_max_size)
NameError: global name 'frozen' is not defined

Change History (4)

comment:1 Changed 3 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

This was caused by r11592 (a difference in logging between 0.16 and trunk as they have already diverged enough to cause this sort of problems), fixed in r11598.

Closing, feel free to re-open if I've messed up something else in this backport.

comment:2 Changed 3 years ago by Antoine Martin

Resolution: fixed
Status: closedreopened

Oops: there were two issues in this ticket, comment:1 is about the "frozen" bit, the "python.version" still remains.

comment:3 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas
Status: reopenednew

This should be fixed in r11604 (see commit message).

comment:4 Changed 3 years ago by alas

Resolution: fixed
Status: newclosed

Yup - 0.16.1 r11604 osx client against 0.16.1 r11607 fedora 23 server builds and runs without any errors.

Closing.

Note: See TracTickets for help on using tickets.