xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1100 closed defect (fixed)

0.16 Windows Clients lose tray icons when scaling

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 0.17
Component: client Version: 0.16.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Follow up from #976.

Client is 16.X Windows 8.1 r11739, and the server is a 16.X Fedora 23 r11764 built from source:

  • Scaling up or down causes the windows to disappear from the tray and re-appear(expected) without their old icons (not-expected.)
  • Reconnecting will get the icons back, but again, upon scaling they are lost.

Attachments (3)

1100xprainfo.txt (162.9 KB) - added by J. Max Mena 4 years ago.
Xpra info as requested
1100 desktop screenshot.png (1.3 MB) - added by J. Max Mena 4 years ago.
re-upload of the screenshot minus Skype and Email inboxes…
1100 Fedora 23 client.png (1.2 MB) - added by J. Max Mena 4 years ago.
Screenshot of the Fedora 23 desktop (XFCE)

Change History (9)

comment:1 Changed 4 years ago by J. Max Mena

Description: modified (diff)

(edited server version, my session info reported the wrong version)

comment:2 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to J. Max Mena

r11812 fixes a bug to do with the systray detected location, which may fix your problem.
I'm not sure since I was not able to reproduce it: although the location was wrong, the systray icon was still visible and still responded to clicks (tested with vlc).
If you can still reproduce the problem, please include more details: maybe a screenshot would help, xpra info always does.

This sounds similar to a number of entries in #976: ticket:976#comment:14, r10802, etc..

comment:3 Changed 4 years ago by J. Max Mena

Owner: changed from J. Max Mena to Antoine Martin

Upped client to trunk r11819 Win8.1, EDIT: and server to trunk r11834:

  • Still an issue
  • Will attach screenshot (of the whole desktop...) and Xpra info

Pass back to me if you need anything else.

Last edited 4 years ago by J. Max Mena (previous) (diff)

Changed 4 years ago by J. Max Mena

Attachment: 1100xprainfo.txt added

Xpra info as requested

Changed 4 years ago by J. Max Mena

Attachment: 1100 desktop screenshot.png added

re-upload of the screenshot minus Skype and Email inboxes...

comment:4 Changed 4 years ago by J. Max Mena

Update:

  • I can now get this issue with a trunk r11834 Fedora 23 client (haven't tried it as much as my monitor doesn't default scale on that machine..)

Changed 4 years ago by J. Max Mena

Attachment: 1100 Fedora 23 client.png added

Screenshot of the Fedora 23 desktop (XFCE)

comment:5 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

Should be fixed in r11835: we save the last window icon and restore it when we re-init the window. Will backport.
(this may also have affected suspend + resume / screensaver detection, which also re-inits the windows: #980)

Please confirm and close. (new beta win32 and Fedora 23 builds are available)

comment:6 Changed 4 years ago by J. Max Mena

Resolution: fixed
Status: newclosed

Tested with the new Windows trunk build r11890:

All working.

Note: See TracTickets for help on using tickets.