xpra icon
Bug tracker and wiki

Opened 18 months ago

Closed 2 months ago

#1145 closed defect (fixed)

pixbuf backend does not support transparency with desktop scaling enabled

Reported by: retog Owned by: Antoine Martin
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description

Most part of the terminal (using xfce4-terminal and terminator) appear black, mainly when the terminal has the focus. I just updated to ubuntu xenial and xpra 0.17.0 both on the client and on the
server (server being a docker container) but the problem is still there. As display manager normally using i3 but the problem also occurs with the standard ubuntu display manager.

I have been experiencing the problem on different ubuntu and fedora versions on different machines including virtual box vms.

On the server side I run a docker container based on https://github.com/retog/docker-dev.

Attachments (1)

xpra-report.zip (261.9 KB) - added by retog 18 months ago.

Download all attachments as: .zip

Change History (11)

Changed 18 months ago by retog

Attachment: xpra-report.zip added

comment:1 Changed 18 months ago by retog

Just found that the problem does not occur when starting with --opengl=yes.

The Sesssion Info - Features shows

Client OpenGL (checked) Intel Open Source Technology Center /Mesa DRI Intel (R) HD graphics 520 (Skylake GT2)

Without the parameter (i.e. when the problem occurs):

Client OpenGL (unchecked) PyOpenGL version 3.1 or later is required (found version 3.0.2)

comment:2 Changed 18 months ago by Antoine Martin

It is probably transparency related, the cairo backend does not get as much testing. And there are issues with virtualbox too.
PyOpenGL 3.1 has been out for years... so we're not going to support anything older than that.

comment:3 Changed 18 months ago by retog

As even the newest ubuntu distro comes with a too old PyOpenGL version the installation instructions should say how to get a compatible version.

comment:4 Changed 18 months ago by Antoine Martin

Milestone: 0.170.18
Status: newassigned
Summary: Text not appearing in terminalspixbuf backend does not support transparency with desktop scaling enabled

As even the newest ubuntu distro comes with a too old PyOpenGL version the installation instructions should say how to get a compatible version.


You should not be messing up with your system installed packages if you don't know how to do that and how to revert it later.

We should just make sure the non-opengl fallback works as it should.
r12148 fixes that by disabling transparency for the non-opengl gtk pixbuf + cairo case, this will be backported to v0.16.x

I am keeping this ticket open because we should really support transparency with cairo, but not a huge priority.

comment:5 Changed 18 months ago by retog

You should not be messing up with your system installed packages

I did not! I installed xpra following exactly the instruction on unmodified ubuntu installations (including xenial).

comment:6 Changed 14 months ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

comment:7 Changed 14 months ago by Antoine Martin

Resolution: wontfix
Status: assignedclosed

I did not! I installed xpra following exactly the instruction on unmodified ubuntu installations (including xenial).


I meant that if your distro supplies an outdated pyopengl, you should not try to install a newer one on top.

In any case, the non-opengl backends are legacy and therefore I am not going to spend time fixing the desktop-scaling + transparency + non-opengl combination.
Especially since most distros will have opengl support in the next release, including outdated Debian + Ubuntu, see #1275.

comment:8 Changed 2 months ago by Antoine Martin

r16261 re-enables transparency with the pixmap backend since I am no longer seeing any visual corruption with desktop-scaling enabled.
Even the cairo backend seems to paint transparency+scaling just fine (both in GTK3 #640 and with GTK2 and XPRA_USE_CAIRO_BACKING=1 env switch).

These changes are now tracked in #1570.

comment:9 Changed 2 months ago by Antoine Martin

Resolution: wontfix
Status: closedreopened

comment:10 Changed 2 months ago by Antoine Martin

Resolution: fixed
Status: reopenedclosed

Tested OK on a number of different OS and backend combinations:

  • debian stretch
  • fedora 26
  • ubuntu 16.04
  • ubuntu 17.04
  • mac os
  • windows...

Works fine!

Note: See TracTickets for help on using tickets.