xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1161 closed defect (fixed)

centos 6 failing with gdp and mka muxers

Reported by: Antoine Martin Owned by: Smo
Priority: blocker Milestone: 0.17
Component: sound Version: trunk
Keywords: centos gdp Cc:

Description (last modified by Antoine Martin)

Testing all the codecs I have available:

  • mp3: OK
  • wav: OK
  • wavpack: OK
  • speex: OK
  • opus / opus+gdp: not available with centos 6 (too old)
  • vorbis, speex+gdp and flac+gdp: server runs OK but the client streams these errors (python:23182): GStreamer-CRITICAL **: gst_segment_to_stream_time: assertion 'segment->format == format' failed, seems this is explained here: GStreamer audio sinks are picky
  • vorbis+mka: server runs OK but the client stops on pipeline error: gst-stream-error-quark: Could not demultiplex stream. (9) - same thing?

Basically, all the codecs that use gdp ("vorbis" does) seem to have a problem.
Setting the format to "time" instead of "buffers" makes no difference.

Already fixed a related bug: r12352.

Change History (2)

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Smo
Priority: criticalblocker

r12356 takes the brutal approach and disables gdp and mka for any version of gstreamer older than 0.10.36, this includes centos 6 but not fedora.
It should default to mp3 again on centos 6.

@smo: is this the bug you were talking about, are those the codecs you tried? were you getting the same stream of messages? The sound does kinda work here, just not very well - could be a platform thing, what did you use for testing?
And more importantly, does the fix work? Do all of the codecs still enabled work with any client / server?
Is the version check too stringent?

Raising: this is a blocker for 0.16.4

comment:2 Changed 4 years ago by Smo

Resolution: fixed
Status: newclosed

Tested this with 0.16.3 client with the 2 issues patched from above and it does what this ticket is trying to accomplish and disable every codec with gdp.

This isn't quite the bug I was talking about so I will have to make another ticket for the scratchy audio.

All of the codecs that should work do work now.

I tested this with 0.17.x server from trunk/testing and also with 0.16.3 server and 0.15.10 server

I might note that I never saw the stream of errors that you got just very poor performance.

I will have to try these in a VM like you have and see if I can reproduce.

Closing this as fixed for this issue.

Note: See TracTickets for help on using tickets.