xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1162 closed defect (fixed)

Microphone forwarding is sending silence sound packets to the server on Ubuntu 15.10 and Ubuntu 16.04.

Reported by: Kundan Owned by: Kundan
Priority: major Milestone: 0.17
Component: sound Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

Reference #1141.

Microphone forwarding on Linux Ubuntu 15.10 and Ubuntu 16.04 (I tested on the beta2 version) is not working properly.

The problem is silence sound packets which are getting sent to the server.

I have found a workaround which is working fine. And, now actual sound packets are getting transferred. I am able to see the line below silence in pavucontrol of the client machine, and that of server. Both are vibrating, proving, that sound is actually getting transferred.

I also tried to record after enabling microphone after making the change. The actual sound data is getting recorded.

But, I don't know why it was getting caused, and why my fix solved the issue.

I am attaching the diff. Please make appropriate changes. So, that others may not face this issue.

Attachments (1)

src.py1.diff (775 bytes) - added by Kundan 4 years ago.
src.py diff, due to which now both pavucontrol on client and server is showing actual sound transfer.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by Kundan

Attachment: src.py1.diff added

src.py diff, due to which now both pavucontrol on client and server is showing actual sound transfer.

comment:1 Changed 4 years ago by Kundan

Component: androidsound

comment:2 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Kundan

Good find!

This is caused by r11771 for #1103. (somewhat related to #1067)
This had also already caused us some problems on OSX and win32: see r12102.

So r12372 disables tuning of "buffer-time" and "latency-time" by default, on all platforms for now. (it can still be re-enabled using the environment variables).
We also keep the code that measures the "actual" values, as we use this for av-sync latency calculations.

@kundanvp: does this work for you?

comment:3 Changed 4 years ago by Kundan

Resolution: fixed
Status: newclosed

Yes, I tested by taking the new src.py file, from the change r12372, and now things are working properly.

Marking it as fixed, as I am not seeing it, after the change r12372.

Note: See TracTickets for help on using tickets.