xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1166 closed defect (fixed)

osx 0.16.4 has "log_both" error in hello packet

Reported by: alas Owned by: alas
Priority: blocker Milestone: 0.17
Component: client Version: trunk
Keywords: Cc:

Description

As a first note, to install the 0.16.4 r12370.pkg (from your /beta repo) I first had to throw all the .dmg applications I'd been collecting into the trash and empty the trash.

Once that was done, I was able to install, but trying to connect (to a 0.17.0 r12385 fedora 23 server) threw a hello packet error and triggered a connection loss:

2016-04-14 12:11:21,412 error in hello packet
Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/client_base.py", line 618, in _process_hello
    self.server_connection_established()
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/ui_client_base.py", line 1599, in server_connection_established
    if XpraClientBase.server_connection_established(self):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/client_base.py", line 645, in server_connection_established
    self.parse_logging_capabilities()
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/ui_client_base.py", line 1804, in parse_logging_capabilities
    if not self.log_both:
AttributeError: 'XpraClient' object has no attribute 'log_both'
2016-04-14 12:11:21,413 error processing hello packet from server: 'XpraClient' object has no attribute 'log_both'
2016-04-14 12:11:21,414 Connection lost

Change History (6)

comment:1 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas
Priority: majorblocker

I cannot reproduce and I really don't see how that's possible.
Please include the exact command lines and/or configuration files that you used.

The log_both attribute is initialized very early in the UI client class.

comment:2 Changed 4 years ago by alas

Owner: changed from alas to Antoine Martin

Interesting... I can't repro it either now?

Wait... spoke too soon.

0.16.4 r12370.pkg connects without a hitch with a 0.16.4 server (didn't note revision).

The above error, with the output, is triggered by connecting the 0.16.4.pkg to a 0.17.0 server.

Server is launched with a standard/habitual command of dbus-launch xpra --no-daemon --bind-tcp=0.0.0.0:1203 --start-child=xterm --start-child=xterm --mdns=no start :13 --start-new-commands=yes.

Client is launched with ./xpra attach tcp:(stuff) -d launcher (without the debug flag, there's no traceback outputted).

To be thorough, I tested the 0.16.4 r12370 application as well... and found that it has the same issue as the .pkg.

comment:3 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas
Summary: osx 0.16.4 r12370.pkg has error in hello packetosx 0.16.4 has "log_both" error in hello packet

Sorry about that, I am so focused on releasing 0.17 that I missed the fact that this ticket title is about 0.16.x

Should be fixed in r12389.

comment:4 Changed 4 years ago by alas

Hmm... tried again with 0.16.4 r12370.pkg against trunk r12432 fedora 23 server, and got the same error (as well as noticing that TRUNK is now 0.18).

I can only presume that the fix is in the client. I'll test again once I manage to get one built (and I'll also have to slap together a 0.17 tagged server build set up while I'm at it, to be thorough).

comment:5 Changed 4 years ago by Antoine Martin

The fix is in the client, as can be seen by following the link to r12389.

comment:6 Changed 4 years ago by alas

Resolution: fixed
Status: newclosed

Tested with 0.16.4 r12444 against a 0.17.0 r12453 fedora 23 server. Connects without a hitch.

Just to satisfy a little OCD, tried against 0.18.0 r12453 fedora 23 server. Also connects without a hitch.

Closing.

Note: See TracTickets for help on using tickets.