xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#1191 closed enhancement (fixed)

Adds shadow-utils as a requirement(pre) of xpra-common in xpra.spec

Reported by: Ronaldo Nunez Owned by: Antoine Martin
Priority: minor Milestone: 1.0
Component: packaging Version: trunk
Keywords: el centos fedora spec shadow-utils Cc:

Description (last modified by Antoine Martin)

Added xpra to a CentOS custom image to install it during the system installation, through Anaconda. When Anaconda tries to install xpra-common the process is exit with an error exit code from the post script:

getent group wireshark >/dev/null || groupadd -r wireshark

The error occurs because groupadd is not available, even it is marked to be installed.

As you can check at the links below, the problem is solved adding "Requires(pre): shadow-utils" to the spec file:

https://bugzilla.redhat.com/show_bug.cgi?id=753293
https://fedoraproject.org/wiki/Packaging:UsersAndGroups

I successfully installed xpra-common, modifying the spec file from xpra-0.17.0-1.el7_2.src.rpm.

Attachments (1)

xpra_shadow-utils-deps-12487.patch (395 bytes) - added by Ronaldo Nunez 4 years ago.
Patch created from trunk rev. 12487 to solve add shadow-utils as a requirement to the spec file.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Ronaldo Nunez

Patch created from trunk rev. 12487 to solve add shadow-utils as a requirement to the spec file.

comment:1 Changed 4 years ago by Ronaldo Nunez

Milestone: 0.18future
Type: defectenhancement
Version: 0.17.xtrunk

comment:2 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks!

Applied in r12488, will be included in the next stable updates as this is cheap.

comment:3 Changed 3 years ago by Antoine Martin

r12750 + r12751 was needed to fix opensuse packaging, backport will be needed too

comment:4 Changed 3 years ago by Antoine Martin

Description: modified (diff)
Milestone: future1.0

(edit milestone)

Note: See TracTickets for help on using tickets.