xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1198 closed defect (fixed)

0.18.0 server with limited resources - AttributeError: 'tuple' object has no attribute 'split'

Reported by: alas Owned by: alas
Priority: minor Milestone: 1.0
Component: server Version: trunk
Keywords: Cc:

Description

Testing with a fedora 23 vm with only 512 MB memory for #1111 - encountered a server error sporadically (not seeing with a server with reasonable resources).

0.18.0 r12578 windows client, 0.18.0 r12577 fedora 23 server.

Ran across the following server-side traceback sporadically as I ran videos while over-using the control channel to adjust the av-sync-delta:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/sound/sound_pipeline.py", line 322, in on_message
    for x in w[1:].split(":"):
AttributeError: 'tuple' object has no attribute 'split'

Change History (5)

comment:1 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

This was caused by r12552. Should be fixed in r12593.

comment:2 Changed 3 years ago by alas

Owner: changed from alas to Antoine Martin

Hmm, oddly... while trying to repro for #1199, this was all I was able to repro.

0.18.0 r12608 fedora 23 server, 0.18.0 r12578 win32 client.

comment:3 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

The line in the ticket description no longer exists, please include the new stacktrace.

comment:4 Changed 3 years ago by alas

Resolution: fixed
Status: newclosed

Been trying to repro, but haven't been able to so far.

I'm actually fairly convinced that I'd mis-read my server/install juggling and repro'd with a different r12577, rather than an r12608.

I'm going to close for now, and only reopen if I manage to trigger/stumble across this again.

comment:5 Changed 3 years ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

Note: See TracTickets for help on using tickets.