xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 10 years ago

Closed 10 years ago

Last modified 17 months ago

#120 closed defect (fixed)

xpra is not working with AFS

Reported by: Martin Vala Owned by: Antoine Martin
Priority: critical Milestone: 0.3
Component: core Version: 0.1.0
Keywords: Cc:

Description (last modified by Antoine Martin)


i found out that xpra is not working on AFS. As long as i know that there are some problems to execute ssh command (or something) on AFS. I had this issue with another program and i solved it when i could execute my stuff outside afs space. In my case not at $HOME. Can we specify external direcotry. Not $HOME?



Change History (6)

comment:1 Changed 10 years ago by Antoine Martin

Status: newaccepted

Have you tried specifying --socket-dir=/tmp/, is that not enough to get it to work?

Why is it failing? The only other thing stored in $HOME are the log files, I can't see why that would be a problem.

In any case, making everything relative to some other directory should be no problem, something like:
(patches to do just that would be most welcome)

comment:2 Changed 10 years ago by Martin Vala

on server side --socket-dir=/tmp/ is working. at least log writes that xpra is ready

then when i do from my laptop

mvala@vala ~ $ xpra attach ssh:lx001.saske.sk:100
Connection failed: [Errno 2] No such file or directory
connection lost: empty marker in read queue
Connection lost


Last edited 10 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 10 years ago by Antoine Martin

Component: androidcore
Description: modified (diff)

Right, we need a way for the client to pass the location of the socket dir through the ssh tunnel, otherwise it tries to find the socket in the usual location.. and fails.
I'll take a look at it.

comment:4 Changed 10 years ago by Antoine Martin

Priority: majorcritical
Resolution: fixed
Status: acceptedclosed

fixed in r785: we now honour the --socket-dir option with ssh tunnels.
We also save the value in the "run-xpra" file, so if you always use "--socket-dir=/tmp" on the server, in theory you should not need to specify it on the client... (but if the last server session you start/try-to-start does not have it... then it will fail, so it is probably best to specify it on the client too)

#123 may provide a better solution to set this value globally

comment:5 Changed 10 years ago by Martin Vala

Thanks, i will try

comment:6 Changed 17 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/120

Note: See TracTickets for help on using tickets.