xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1225 closed defect (fixed)

Paint issues on latest trunk

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 1.0
Component: server Version: trunk
Keywords: Cc:

Description

This is a spinoff from #1218

I'll attach the relevant xpra info and a quick video with the paint boxes enabled. I'm honestly not sure what's up - It works fine if I roll back to r12730, but somewhere between there and r12758 it breaks. I've tried bisecting but I had no luck even after a full day of incrementally rolling through the build revisions. Somewhere around r12750 it breaks.

Once I get it broken, the repro is interesting. I don't get it with Xterms, and with Chrome it's sporadic. It's most easy to hunt down in Firefox.

  • Open Firefox
  • Try to highlight some text
    • It may or may not work
    • If it highlights fine then try scrolling up and down first
      • I find that's the easiest way to repro this

Start command:

xpra start :13 --bind-tcp=0.0.0.0:2200 --start-new-commands=yes --start-child=xterm --start-child="xterm -bg black -cr white -fg white" --start-child="xterm -bg black -cr white -fg white"

And connecting:

xpra attach tcp:ip:port

and sometimes:

XPRA_OPENGL_PAINT_BOX=1 xpra attach tcp:ip:port


For what it's worth, the server is a Fedora 23 hardware machine running Fedora Server. The client is also hardware, but has an Nvidia 745 GPU, the server only Intel. I also run into this issue with AND without OpenGL enabled.

Attachments (3)

1225 paint isues.mp4 (3.3 MB) - added by J. Max Mena 4 years ago.
Video of the paint issue. Note that the pauses in between are me clicking to highlight text.
1225xprainfo.txt (141.0 KB) - added by J. Max Mena 4 years ago.
1218-paint issues in Firefox.mp4 (2.8 MB) - added by J. Max Mena 4 years ago.
The original video file for good measure

Change History (8)

Changed 4 years ago by J. Max Mena

Attachment: 1225 paint isues.mp4 added

Video of the paint issue. Note that the pauses in between are me clicking to highlight text.

Changed 4 years ago by J. Max Mena

Attachment: 1225xprainfo.txt added

Changed 4 years ago by J. Max Mena

The original video file for good measure

comment:1 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

Please include the bisection data. Even an unsuccessful bisection generates some data which may be useful in hunting down the bug. For an example of bisection data logging see ticket:557#comment:1

Also, please verify that this is a regression by testing the latest 0.17.x (and even maybe 0.14.x), bearing in mind that the bug may be present there and just harder to hit.

Does this also occur if you start the server with XPRA_VIDEO_SUBREGION=0?

Does this patch help? attachment/ticket/1218/track-nonvideo.patch

Of all the commits between r12730 and r12750:

  • r12730 to r12739 are very very unlikely to cause problems as they either apply to v0.17.x branch, fix typos or build issues
  • r12740 should only be relevant when using the video region API to set one
  • r12741 is unlikely
  • r12742 + r12743 should only affect the server xvfb startup / cleanup code, very unlikely
  • r12744 could be the cause (the fix for #1218), could leave some areas not repainted
  • r12745 + r12746 + r12747 + r12748 + r12749 + r12750 are all extremely unlikely to cause problems (packaging and logging changes)
Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 4 years ago by J. Max Mena

Owner: changed from J. Max Mena to Antoine Martin

Retested a couple times:

  • Latest trunk with XPRA_VIDEO_SUBREGION=0 doesn't seem to trigger the issue
  • The given patch had no effect on latest trunk
  • As per your comment (comment:1), I zeroed in on r12744, and found that to be the revision where the break is introduced
  • Issue does not show up in the latest 0.17.X branch.

comment:3 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

comment:4 Changed 4 years ago by J. Max Mena

Resolution: fixed
Status: newclosed

As per #1218, it looks like this one is fixed in r12780.

Closing, but will keep a good eye out for this one in case we see it again.

comment:5 Changed 4 years ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

Note: See TracTickets for help on using tickets.