xpra icon
Bug tracker and wiki

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1239 closed defect (invalid)

HTML Server spewing name error tracebacks

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 1.0
Component: html5 Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

I have a feeling it has to do with the fixes due to #1218.

With a trunk built r12890 server and connecting with Google Chrome:

  • I get the following traceback many times per second. It's actually interfering with my ability to test a couple other HTML5 tickets.
NameError: global name 'excluded' is not defined
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1112, in expire_delayed_region
    self.may_send_delayed()
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1211, in may_send_delayed
    self.do_send_delayed()
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1223, in do_send_delayed
    self.send_delayed_regions(*delayed)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1239, in send_delayed_regions
    self.do_send_delayed_regions(damage_time, regions, coding, options)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_video_source.py", line 579, in do_send_delayed_regions
    return send_nonvideo(get_best_encoding=self.get_best_encoding)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_video_source.py", line 570, in send_nonvideo
    WindowSource.do_send_delayed_regions(self, damage_time, regions, encoding, options, exclude_region=exclude_region, get_best_encoding=get_best_encoding)
  File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_source.py", line 1332, in do_send_delayed_regions
    return excluded
NameError: global name 'excluded' is not defined

The html client does appear to work okay, if a little slow.

Change History (6)

comment:1 Changed 2 years ago by J. Max Mena

Description: modified (diff)
Summary: HTML Server spewing name error tracebacksServer spewing name error tracebacks

Update:

I see this even with connecting with a regular Python client, and even with HTML disabled. Updating the ticket to reflect this.

comment:2 Changed 2 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Josh to J. Max Mena
Summary: Server spewing name error tracebacksHTML Server spewing name error tracebacks

Hmmm, are you sure of the state of your source tree?
I can find no such code anywhere:

$ grep -r "excluded" xpra/ | wc -l
0

Not even in older branches.
And line 1332 doesn't have it either: browser/xpra/trunk/src/xpra/server/window/window_source.py

comment:3 Changed 2 years ago by J. Max Mena

Hmmmm.

I turfed my source tree and re-downloaded trunk to be sure, before I turfed it it found 13, and now it says 8.

For what it's worth, after rebuilding, I no longer get that error, but I do see:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_base.py", line 2328, in _process_sound_control
    ss.sound_control(*packet[1:])
  File "/usr/lib64/python2.7/site-packages/xpra/server/source.py", line 1124, in sound_control
    self.set_av_sync_delay(int(args[0]))
  File "/usr/lib64/python2.7/site-packages/xpra/server/source.py", line 1187, in set_av_sync_delay
    self.update_av_sync_delay_total()
  File "/usr/lib64/python2.7/site-packages/xpra/server/source.py", line 1210, in update_av_sync_delay_total
    ws.set_av_sync_delay(self.av_sync_delay_total)
TypeError: set_av_sync_delay() takes exactly 1 argument (2 given)

a couple times on connect, but it seems to run fine now.

Weird.

comment:4 Changed 2 years ago by Antoine Martin

set_av_sync_delay() takes exactly 1 argument (2 given)


This one is real, caused by r12868 and should be fixed in r12891.

comment:5 Changed 2 years ago by J. Max Mena

Resolution: invalid
Status: newclosed

Okay, then it was my source tree. I'm gonna go ahead and close this as invalid.

Thanks for the help.

comment:6 Changed 2 years ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

Note: See TracTickets for help on using tickets.