xpra icon
Bug tracker and wiki

Opened 2 years ago

Closed 23 months ago

#1277 closed defect (fixed)

osx delegate error

Reported by: Antoine Martin Owned by: alas
Priority: major Milestone: 1.0
Component: platforms Version: trunk
Keywords: osx Cc:

Description

Seen from the launcher when re-connecting:

Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py", line 370, in ready
    self.setup_event_listener()
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py", line 385, in setup
_event_listener
    class Delegate(NSObject):
error: Delegate is overriding existing Objective-C class

Could be caused by the sleep / wake (#1137 / r12271) or the tray deiconify hook. (#965 / r12162)
Probably something we should not be re-instantiating or re-initialising when we connect again.

Originally recorded here: ticket:1240#comment:1.

Change History (3)

comment:1 Changed 2 years ago by Antoine Martin

Status: newassigned

See #1163 handle xpra:// urls on osx which may need the delegate code..

comment:2 Changed 23 months ago by Antoine Martin

Owner: changed from Antoine Martin to alas
Status: assignednew

This was 100% reproducible by connecting using the launcher to a server, causing a connection timeout (ie: control-z the server process) which brings up the launcher again with the "connection lost" warning, then re-connect to a server. (ie: the same one by resuming it with "fg").

Fixed in r13583 (works for me), hopefully without breaking power events.
Also fixes the "GURL" warning.

@afarr: please close if OSX power events still work. (see #1137)

Last edited 23 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 23 months ago by alas

Resolution: fixed
Status: newclosed

Tested with 1.0 r13590 osx client (10.9) and same version fedora 23 server.

Once I realized I also had to run a "bg" command after the control-z, in order for the "fg" to make the server active again, this worked for me as well.

Tested both a display timeout sleep and sleep option from the apple menu, worked fine in both cases.

Looks good. Closing.

Note: See TracTickets for help on using tickets.