xpra icon
Bug tracker and wiki

Opened 8 months ago

Closed 4 weeks ago

#1281 closed defect (worksforme)

xpra ssh mode cannot connect from mac gui launcher

Reported by: DavidE Owned by: DavidE
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description

I have a Ubuntu server running a session on Display :30

I can connect/disconnect from it remotely and even locally on my mac through ssh -X (which defeats the point).

However, whenever I try the xpra launcher with all the right settings, I just get the red 'Connection lost' with no explanation. Also, there is no documentation.

Maybe if I had the command-line version of xpra I could try
attach but I can't find it for MAC. This could be really good, but as is, it is unusable. Such a shame...

Attachments (4)

Screen Shot 2016-08-10 at 11.02.16.png (771.1 KB) - added by DavidE 8 months ago.
xpra_bug_report_20160814.zip (521.2 KB) - added by DavidE 8 months ago.
Screen Shot 2016-08-15 at 09.06.39.png (821.4 KB) - added by DavidE 8 months ago.
Attempt from Ubuntu to Ubuntu
Unable to connect via SSH.zip (1.9 MB) - added by Alain Kalker 4 weeks ago.
Bug Report information

Change History (21)

comment:1 Changed 8 months ago by Antoine Martin

Owner: changed from Antoine Martin to DavidE

What version are you using?
What mode are you using to try to connect?
What commands lines are you using to start xpra? Does it work if you connect from Ubuntu?
etc.. for more guidelines, see wiki/ReportingBugs.

Xpra is used every day on macs.

The Xpra executable will be on your path if you use the PKG installer, otherwise it will be found in Xpra.app/Contents/Helpers/Xpra

Finally, there is tons of documentation, here on this wiki and via the xpra man page.

Changed 8 months ago by DavidE

comment:2 Changed 8 months ago by Antoine Martin

Resolution: duplicate
Status: newclosed

So you're using SSH mode, you may want to try the latest beta osx builds which include a fix for ssh mode.
Or use ssh keys.

See #1240

comment:3 Changed 8 months ago by Antoine Martin

Summary: xpra doesn't work on macxpra ssh mode cannot connect from mac gui launcher

comment:4 Changed 8 months ago by Antoine Martin

comment:5 Changed 8 months ago by DavidE

Resolution: duplicate
Status: closedreopened

The Beta version still doesn't work with my El Capitan.

I tried at commandline

./Xpra ssh:username@ipaddress:display

and got the error

xpra: error: invalid mode 'initenv'

comment:6 Changed 8 months ago by Antoine Martin

Resolution: invalid
Status: reopenedclosed

Had you replied to my questions in comment:1, which I have now repeated numerous times, we would all have saved a lot of time.
Your xpra version on the server is too old. More details here: wiki/Versions


Also, please always include the exact command you typed (cut&pasting them), the ones from comment:5 are made up, and wrong.

Last edited 8 months ago by Antoine Martin (previous) (diff)

comment:7 Changed 8 months ago by DavidE

Resolution: invalid
Status: closedreopened

It is true the previous server was old.

However I just tried the beta version with an xpra session on a
brand new server and got the error

'server requested disconnect: login timeout

[El Capitan trying to connect to current Ubuntu]

comment:8 Changed 8 months ago by DavidE

I tried connecting through ssh -X on this server and got lots of libGL errors

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
The program 'Xpra' received an X Window System error.
This probably reflects a bug in the program.
The error was 'GLXBadContext'.
  (Details: serial 261 error_code 160 request_code 150 minor_code 6)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Last edited 8 months ago by Antoine Martin (previous) (diff)

comment:9 Changed 8 months ago by Antoine Martin

Status: reopenednew

opengl has nothing to do with your problem, no idea what "I tried connecting through ssh -X" means since you're still not including the actual commands you used.

Try with the latest beta, which will allow you to disable ssh host key checking. Maybe you never connected to that SSH server before and SSH strict host key checking is enabled but without support for GUI confirmation.


Here's what a proper debugging information looks like:

  • server
    $ echo $USER
    test
    $ rpm -qa xpra
    xpra-1.0-0.20160811r13304.fc24.x86_64
    $ xpra start --start=xterm --bind-tcp=0.0.0.0:10000 :100
    

(and keep an eye on your server log)

  • osx client from GUI:
    open Desktop/Xpra-1.0-r13304.dmg
    open /Volumes/Xpra/Xpra.app
    
  • osx client from command line:
    open Desktop/Xpra-1.0-r13304.dmg
    /Volumes/Xpra/Xpra.app/Contents/Helpers/Xpra attach ssh/test:testpassword@HOST/100
    

(you can omit the display part if you have a single server session running)

Unless you can provide similar details showing your exact problem, in particular any output or error messages, I will close this bug.

comment:10 Changed 8 months ago by DavidE

OK I will try tomorrow

Changed 8 months ago by DavidE

comment:11 Changed 8 months ago by Antoine Martin

Info still missing. How many times can I ask for the same thing? This will be the last.
See comment:1 and ticket:1240#comment:9, comment:9 right above for an example.

Changed 8 months ago by DavidE

Attempt from Ubuntu to Ubuntu

comment:12 Changed 7 months ago by DavidE

OK - I tried your suggestion to test whether Ubuntu would connect,
and the answer was 'no' for the new server. [see attachment 3]

I had tested the old server [Ubuntu 10.2] for the same thing and it had worked. I hadn't checked the new one for this
but it appears this could be the issue - that the current version of Xpra
is not compatible with Ubuntu 16 without further tweaking.

comment:13 Changed 7 months ago by Antoine Martin

Resolution: needinfo
Status: newclosed

The current version of xpra for Ubuntu xenial is 0.17.4, more details here: wiki/Versions - same as comment:6.
Details as per comment:9 are still missing too, so I'm done.

Changed 4 weeks ago by Alain Kalker

Bug Report information

comment:14 Changed 4 weeks ago by Alain Kalker

Dear Antoine,

Please, could you drop the condescending tone, get some sleep, whatever. Not all users of Xpra are professional bug reporters, or even have any experience in reporting problems.

I think I'm having a similar problem to DavidE: I'm unable connect to a Linux server using the GUI part of Xpra for Mac OS.

I'm attaching a zip file which was saved after clicking the "Bug Report" icon in the Xpra GUI.

comment:15 Changed 4 weeks ago by Alain Kalker

Resolution: needinfo
Status: closedreopened

comment:16 Changed 4 weeks ago by Alain Kalker

Tried to repro just to be absolutely sure but I was unable to. There was a problem with the connection between the Mac client and Linux server, unrelated to Xpra.
After fixing this, both commandline xpra attach and the GUI worked well.

It would have been nice if the error message reported by the GUI had been more indicative of the root cause of the problem.

comment:17 Changed 4 weeks ago by Alain Kalker

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.