xpra icon
Bug tracker and wiki

#1286 closed defect (invalid)

printing conflicts with socket authentication module 'env'

Reported by: alas Owned by: Antoine Martin
Priority: major Milestone: 1.0
Component: server Version: trunk
Keywords: Cc:

Description

Testing authentication with 1.0 r13101 win32 client against 1.0 r13401 (unknown changes) fedora 23 server, I got the warning Warning: printing conflicts with socket authentication module 'env' when setting the tcp-auth on the server using --auth=env syntax (while using an environment variable to set the password), or when using the --auth=password:value=my-password syntax.

Sure enough, the warning is legitimate.

Testing the printing with -d printing both server and client side shows nothing client side, but the following clear problem server side:

2016-08-19 12:00:45,782 local sockets we can use for printing: ['/var/run/user/1001/xpra/jimador.plata-13', '/home/jimador/.xpra/jimador.plata-13']
2016-08-19 12:00:45,782 xpra X11 version 1.0-r13401 64-bit
2016-08-19 12:00:45,783  running with pid 12604 on Linux Fedora 23 TwentyThree
2016-08-19 12:00:45,783  connected to X11 display :13
xterm: cannot load font '-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1'
2016-08-19 12:00:45,833 xpra is ready.
2016-08-19 12:00:45,889 pycups settings: DEFAULT_CUPS_DBUS=1, CUPS_DBUS=True, POLLING_DELAY=60
2016-08-19 12:00:45,889 pycups settings: PRINTER_PREFIX=, ADD_LOCAL_PRINTERS=False
2016-08-19 12:00:45,889 pycups settings: ALLOW=jimador
2016-08-19 12:00:45,889 pycups settings: FORWARDER_TMPDIR=/tmp
2016-08-19 12:00:45,889 pycups settings: SKIPPED_PRINTERS=['Cups-PDF']
2016-08-19 12:00:45,889 DEFAULT_CUPS_OPTIONS={'fit-to-page': 'True'}
2016-08-19 12:00:45,890 get_printer_definitions() UNPROBED_PRINTER_DEFS={'application/postscript': ['-m', 'drv:///sample.drv/generic.ppd'], 'application/pdf': ['-P', '/usr/share/ppd/cupsfilters/Generic-PDF_Printer-PDF.ppd']}, GENERIC=True
2016-08-19 12:00:45,893 get_mimetype()=['application/pdf', 'application/postscript']
2016-08-19 12:00:45,893 pycups settings: PRINTER_DEF={'application/postscript': ['-m', 'drv:///sample.drv/generic.ppd'], 'application/pdf': ['-P', '/usr/share/ppd/cupsfilters/Generic-PDF_Printer-PDF.ppd']}
2016-08-19 12:00:45,893 printer forwarding enabled using postscript and pdf
2016-08-19 12:00:45,893 Warning: printing conflicts with socket authentication module 'password'
2016-08-19 12:00:45,893 init_printing() printing=False

(These logs were taken from a test with the --auth=password:value=my-password syntax, presumably it would be the module 'env' conflicting if that module was used.)

Change History (1)

comment:1 Changed 15 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

Not a bug: we do not want to expose the password in the printer properties.

See ticket:598#comment:7 : r8690 deals with socket permissions by adding tcp-auth, so we can now start the server without any authentication required on the local socket.

Don't use the "auth" flag socket authentication, use "tcp-auth" if you need authentication on TCP sockets.

Eventually, we'll deal with #1160 so that we can have both shared unix domain sockets with authentication (ie: the ones we can place in /var/run/xpra) and others without (which we can then use for printing)

Note: See TracTickets for help on using tickets.