xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1292 closed defect (fixed)

Unable to sigint to detach on latest 1.0 OSX Beta

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description (last modified by J. Max Mena)

Running the r13447 Xpra 1.0 OSX beta client, I am unable to control-c the Terminal output to detach. Upon doing so, the client hangs after printing sound output stopping. The latest 0.17.5 (r13418) client is unaffected, and works as expected when giving a sigint.

Detaching by using cmd+Q into any open Xpra window works as expected, and will work as a workaround in the meantime.

Attachments (3)

Screen Shot 2016-08-24 at 10.54.43 AM.png (102.8 KB) - added by J. Max Mena 3 years ago.
The terminal window after siginting
Screen Shot 2016-08-24 at 11.33.37 AM.png (102.8 KB) - added by J. Max Mena 3 years ago.
Re-test same effect with ogg container
1292dall.txt (323.7 KB) - added by J. Max Mena 3 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 3 years ago by J. Max Mena

Description: modified (diff)

Update latest client revision number - didn't notice the new client because of Chrome caching. Still an issue with the r13448 client.

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 years ago by J. Max Mena

Description: modified (diff)

Typo in Trunk client version number

comment:3 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

I thought this could have been caused by r13299 + r13361, or even r13423.
But I cannot reproduce the problem with any recent beta versions. (and I've tried quite a few)

How did you come to the conclusion that "the client hangs"? Is it disconnected from the server? Can you run "xpra disconnect" on the server to end to make it exit? Does it still respond to clicks? Is the apple menu responsive?
Could this be related to #1276? (different sound codecs? does it work without sound?)
Can you get the "-d all" client output?
Does hitting control-c again help?

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 3 years ago by Antoine Martin

I think I saw it during testing for #1276, but it only occurred with the problematic gdp options. Now that they are removed, I cannot reproduce this at all.
In any case, r13454 may help: we try harder to force the sound subprocess to exit. (untested since the problem no longer seems to occur)

Changed 3 years ago by J. Max Mena

The terminal window after siginting

comment:5 Changed 3 years ago by Antoine Martin

From the screenshot you are using gdp, so please see per comment:4.
If that's not the cause, see also the questions from comment:3.

comment:6 Changed 3 years ago by J. Max Mena

Retested with an ogg container - still an issue. Will attach another screenshot. (I also filled out the comment field here, but never actually clicked submit. My bad.

Last edited 3 years ago by J. Max Mena (previous) (diff)

Changed 3 years ago by J. Max Mena

Re-test same effect with ogg container

comment:7 Changed 3 years ago by J. Max Mena

From comment:3:

  • I came to the conclusion that it hung when the last print was "stopping sound", and then it never completely exits. I have to close the Terminal app to get it to go away. The terminal sits there and doesn't get me back to bash.
  • I doubt it's related to #1276 - I get it on all the codecs, at least from what I try
  • Will attach -d all output
  • Hitting control-c again doesn't help.
  • Will try xpra disconnect from the server
  • Apple menu disappears, all windows vanish, but the Xpra icon stays in the dock. It looks like it's disconnecting but not fully cleaning up.
Version 1, edited 3 years ago by J. Max Mena (previous) (next) (diff)

Changed 3 years ago by J. Max Mena

Attachment: 1292dall.txt added

comment:8 Changed 3 years ago by Antoine Martin

I've tried hard to reproduce and I just cannot get it to misbehave.
Please try to narrow it down from the beta versions, when did it start?
Does it affect all OSX versions? Does sound matter (turn it off), clipboard, etc?
Failing all this, a gdb backtrace of the stuck process could help.

comment:9 Changed 3 years ago by J. Max Mena

Resolution: fixed
Status: newclosed

I've tried hard to reproduce and I just cannot get it to misbehave.


The r13478 build fixes the issue - From comment:4:


In any case, r13454 may help: we try harder to force the sound subprocess to exit. (untested since the problem no longer seems to occur)


It looks like that's the one that fixed it - I was waiting on a new beta build (I thought I left that info in a comment, I guess it must have slipped through) to test as the (then) current version was r13451 that did not include the fix. The current r13478 build exits immediately, unlike the earlier builds which hung.


The latest changes you included definitely fixed the issue, so I'm going to mark this as fixed. If you'd like me to bi-sect and/or turn off features one by one, re-open this - But, since it's not hanging anymore I don't feel it's necessary as it's fixed.

Note: See TracTickets for help on using tickets.