xpra icon
Bug tracker and wiki

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1301 closed defect (fixed)

win32 client 1.0 r13637 disconnects when Session Info is opened, with opengl enabled

Reported by: alas Owned by: alas
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description

Testing with win32 1.0 r13637 client against a 1.0 r13641 fedora 23 server, when opening the Session Info (either with the shift-alt-F11 keyboard shortcut or the tray option) the client disconnects with the following traceback (posting the traceback, the full error message was long so I'll also attach as a separate file).

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/net/protocol.py", line 301, in _write_format_thread_loop
    self._add_packet_to_queue(*gpc())
  File "/usr/lib64/python2.7/site-packages/xpra/net/protocol.py", line 313, in _add_packet_to_queue
    chunks = self.encode(packet)
  File "/usr/lib64/python2.7/site-packages/xpra/net/protocol.py", line 530, in encode
    main_packet, proto_flags = self._encoder(packet)
  File "/usr/lib64/python2.7/site-packages/xpra/net/packet_encoding.py", line 89, in do_rencode
    return  rencode_dumps(data), FLAGS_RENCODE
  File "/rencode/rencode.pyx", line 334, in rencode._rencode.dumps (rencode/rencode.c:4720)
  File "/rencode/rencode.pyx", line 314, in rencode._rencode.encode (rencode/rencode.c:4508)
  File "/rencode/rencode.pyx", line 247, in rencode._rencode.encode_list (rencode/rencode.c:3321)
  File "/rencode/rencode.pyx", line 317, in rencode._rencode.encode (rencode/rencode.c:4541)
  File "/rencode/rencode.pyx", line 264, in rencode._rencode.encode_dict (rencode/rencode.c:3826)
  File "/rencode/rencode.pyx", line 317, in rencode._rencode.encode (rencode/rencode.c:4541)
  File "/rencode/rencode.pyx", line 259, in rencode._rencode.encode_dict (rencode/rencode.c:3650)
  File "/rencode/rencode.pyx", line 317, in rencode._rencode.encode (rencode/rencode.c:4541)
  File "/rencode/rencode.pyx", line 264, in rencode._rencode.encode_dict (rencode/rencode.c:3826)
  File "/rencode/rencode.pyx", line 317, in rencode._rencode.encode (rencode/rencode.c:4541)
  File "/rencode/rencode.pyx", line 259, in rencode._rencode.encode_dict (rencode/rencode.c:3650)
  File "/rencode/rencode.pyx", line 317, in rencode._rencode.encode (rencode/rencode.c:4541)
  File "/rencode/rencode.pyx", line 258, in rencode._rencode.encode_dict (rencode/rencode.c:3639)
  File "/rencode/rencode.pyx", line 320, in rencode._rencode.encode (rencode/rencode.c:4575)
Exception: type <type 'xpra.server.window.region.rectangle'> not handled

Checking with 1.0 r13520 win32 client the Session Info opens as expected (with or without opengl enabled).

Double checking the r13637 win32 client without using the --opengl=on flag (to get around my Intel driver), I also see no errors. Not sure if this is an Intel issue, but I think maxmylyn ran across the same thing with Nvidia.

Attachments (1)

ticket1301-server-error-message_on-client-session-info-request.txt (95.3 KB) - added by alas 2 years ago.
full server-side error message

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by alas

full server-side error message

comment:1 Changed 2 years ago by alas

Additional note - while poking around osx client issues reported in #1302, I began seeing this behavior in the osx 1.0 r13637 client as well, but irregularly (maybe the third time I tried to open a Session Info window), and I was seeing it on the osx client whether I forced the opengl=on or not.

Ohh, and when the osx client disconnects, it is also hanging, requiring a force quit.

Last edited 2 years ago by alas (previous) (diff)

comment:2 Changed 2 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

This was caused by r13639 (debugging of video regions, see ticket:967#comment:27) and is fixed in r13642 + r13643.


Ohh, and when the osx client disconnects, it is also hanging, requiring a force quit.


Is this related? Does it occur if you don't use session info?. If not, please file a separate ticket.

comment:3 Changed 2 years ago by alas

D'oh - downloaded win32 1.0 r13644 client, but something must've gone awry in the build, because I can't install (windows 8.1 keeps prompting me to search for an app to open it).

(The osx client disconnection hanging seemed to only be happening with Session Info opening triggered disconnections, by the way... but the new osx client build seems to have gone similarly awry. I'll double check when I'm testing for #1302 to be sure though.)

comment:4 Changed 2 years ago by Antoine Martin

I've posted new builds and included both the EXE and ZIP version.
Also, can't you make your own builds?

comment:5 Changed 2 years ago by alas

Resolution: fixed
Status: newclosed

Huh, didn't even think to look for a .zip version.

The .exe you posted is not installing though. Trying with the .zip, it took so long to connect that I thought it wasn't going to work, but in the end it did connect and I was able to open Session Info without any problems.

Closing.

(And no, I can't make my own win32 client builds, but I can ask Smo nicely. Not sure the state of his build system currently, but I'll ask him double-plus nicely and see what happens.)

comment:6 Changed 2 years ago by Antoine Martin

I have tried the latest EXE as well as a few more older revisions, on winxp, win7 and win8.1. Works fine every time, so my guess is that you're doing something different.
When did the problem start? Did you verify that it isn't a problem on your system by installing a known "good" version? What build revision is the first one to fail? etc..

Last edited 2 years ago by Antoine Martin (previous) (diff)

comment:7 Changed 2 years ago by alas

Maybe I was just having issues with my downloading yesterday?

Just downloaded a new copy of 1.0 r13673 and launched, no problems. (I had been able to install previously downloaded builds, just not the ones downloaded yesterday.)

I'd close this again if I could, as is, I'll just scratch my head over what happened and move on.

Note: See TracTickets for help on using tickets.