xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1302 closed defect (worksforme)

osx client 1.0 r13637 throwing handshake_complete errors on connection

Reported by: alas Owned by: alas
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description

Testing with osx 1.0 r13637 client against 1.0 r13641 fedora 23 server (to check behavior against #1301), I'm seeing a handshake callback error client and server side, with or without opengl forced on (more Intel).

Client side.

2016-09-09 11:43:45,555 Error processing handshake callback <function add_ah at 0x876fe70>
Traceback (most recent call last):
  File "/Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-13637/Xpra.app/Contents/Resources/lib/python/xpra/client/ui_client_base.py", line 1951, in handshake_complete
    cb(*args)
  File "/Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-13637/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/osx_menu.py", line 229, in add_ah
    actions_menu.add(self.make_startnewcommandmenuitem())
AttributeError: 'OSXMenuHelper' object has no attribute 'make_startnewcommandmenuitem'

In addition, each time I close a Session Info window I get that last error repeated.

  File "/Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-13637/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/osx_menu.py", line 229, in add_ah
    actions_menu.add(self.make_startnewcommandmenuitem())
AttributeError: 'OSXMenuHelper' object has no attribute 'make_startnewcommandmenuitem'

Server side, on connection, I'm seeing:

2016-09-09 10:42:37,727 client 3: Error processing handshake callback <function add_ah at 0x9e6fe30>
2016-09-09 10:42:37,728 client 3:   File "/Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-13637/Xpra.app/Contents/Resources/lib/python/xpra/client/ui_client_base.py", line 1951, in handshake_complete
2016-09-09 10:42:37,728 client 3:     cb(*args)
2016-09-09 10:42:37,735 client 3:   File "/Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-13637/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/osx_menu.py", line 229, in add_ah
2016-09-09 10:42:37,735 client 3:     actions_menu.add(self.make_startnewcommandmenuitem())

Change History (4)

comment:1 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

This was caused by r13584 and is fixed in r13644.

FYI: the server side message you see is identical to the client's, thanks to remote logging (#786).

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 years ago by alas

Owner: changed from alas to Antoine Martin

Downloaded your new 1.0 r13644 osx client, but I can't install it. Looks like it went awry same as the win32 client (#1301).

Handing this back to you to be sure you see the message, though I'll re-visit if I can manage to build a new client on our end before you get a chance.

comment:3 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

"can't install it" - please explain what happens in more detail.
There is an updated DMG and PKG just posted so you can try both.
Maybe you can try making your own builds too?

comment:4 Changed 3 years ago by alas

Resolution: worksforme
Status: newclosed

"Can't install it" - when I downloaded that client, then tried to double-click the file to "mount" it, so I could then install in my usual strange location... rather than the usual "mount window" (the window that opens with an icon for the Xpra application and the icon for the Applications directory in order to make the drag-install as easy and convenient as imaginable)... I get a system message saying There is no application set to open the document “Xpra-1.0-r13644”., which then presents me a button to "Choose Application..." to open it with, a "Cancel" button, as well as a "Search App Store" button amongst which to choose.

I chose "Cancel".

The 13647.dmg is working fine though... so I'll just close this (and maybe one day I'll see about making the time to try to get someone to show me the ropes of making clients of my own).

Note: See TracTickets for help on using tickets.