xpra icon
Bug tracker and wiki

Opened 2 years ago

Closed 2 years ago

#1324 closed defect (fixed)

icon on indicator applet missing.

Reported by: Jiang Owned by: Jiang
Priority: blocker Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

The icon on the indicator applet in the client desktop that is used to control xpra and getting statistics is missing.

Both the server and the client is on Ubuntu 14.04 64-bit. The server is running r13850, but it also happens on server r13691.

It seems to be the client that's the problem. The problem does not happen when the client is running r13691, but when it is running the latest r13850, the icon is missing on the client indicator applet on the task bar. The icon is missing also in client version r13767, so something must happened between r13691 and r13767.

My desktop environment on the client is gnome-flashback and metacity window manager. I use indicate-applet-complete package for the indicator on the system tray.

I start xpra on the server using command:

XPRA_CLIPBOARD_LIMIT=30 xpra --xvfb='Xorg -noreset -nolisten tcp +extension GLX +extension RANDR +extension RENDER -logfile ${HOME}/.xpra/Xvfb-10.log  -config ${HOME}/.xpra/xorg.conf' start :100 --bind-tcp=0.0.0.0:10000

I connect to server using command on client:

XPRA_SET_WORKSPACE=1 xpra --opengl=yes --encoding=rgb --packet-encoder=rencode --speaker=off --speaker-code=wav --compressor=lz4 --desktop-scaling=off attach tcp:workstation:10000

There is no significant error messages on server. On client I get the following error messages but I don't know whether they are relevant:

Warning: invalid option: 'proxy-start-sessions'
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
  import gobject._gobject

Change History (3)

comment:1 Changed 2 years ago by Antoine Martin

Description: modified (diff)
Status: newassigned

Probably caused by the changes in #1207 (likely r13734).

FYI: until this is fixed, you can access the xpra menu with the keyboard shortcut Meta+Shift+F1 on any xpra window.

comment:2 Changed 2 years ago by Antoine Martin

Owner: changed from Antoine Martin to Jiang
Status: assignednew

Thanks for reporting this! (only affected appindicator)
Fixed in r13876, new beta packages posted.


FYI: you don't need to set all these options every time you run xpra:

cat > ~/.xpra/xpra.conf <<EOF
xvfb='Xorg -noreset -nolisten tcp +extension GLX +extension RANDR +extension RENDER -logfile ${HOME}/.xpra/Xvfb-10.log  -config ${HOME}/.xpra/xorg.conf'
env=XPRA_CLIPBOARD_LIMIT=30
#client options:
env=XPRA_SET_WORKSPACE=1
#this is the default already (redundant):
#packet-encoder=rencode
#compressor=lz4
opengl=yes
encoding=rgb
speaker=off
speaker-codec=wav
desktop-scaling=off
EOF

Then your commands to start and connect become just:

xpra start :100 --bind-tcp=0.0.0.0:10000
xpra attach tcp:workstation:10000

Alternatively, you can place the client-side settings in an ".xpra" file and double-click on it, or run it with "xpra_launcher thesettingsfile.xpra".

comment:3 Changed 2 years ago by Jiang

Resolution: fixed
Status: newclosed

Thank you! This is indeed fixed in the latest beta version! Thank you for fixing it so quickly!

Note: See TracTickets for help on using tickets.