xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 5 years ago

Closed 5 years ago

Last modified 3 months ago

#1337 closed defect (fixed)

xpra_launcher.exe produces a log file alert dialog on exit

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 1.0
Component: platforms Version: trunk
Keywords: win32 Cc:

Description


Change History (2)

comment:1 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Bisection: (argb codec needed revision r13763 to build on win32 to test)

Sub-bisecting the large r13756 changeset as there's no obvious problem with it:

  • "client" module revert: no fix
  • "codecs" and "server" module revert: no fix
  • "x11" "net" and "clipboard" module revert: no fix
  • "sound" and "gtk_common" module revert: no fix
  • "platform" module revert fixes it:

Sub-bisecting "platform" module:

  • "platform.win32" is where the problem is.

Sub-bisecting that, leads to this tiny innocuous change as being the source of the problem: http://xpra.org/trac/changeset/13756/xpra#file42.

Somehow, importing "xpra.util" from "xpra.platform.win32" seems to have some bad side-effects, so r14111 delays the import until we actually need it and that fixes the problem.
I don't really understand why, but I don't have time to look into it either.

comment:2 Changed 3 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1337

Note: See TracTickets for help on using tickets.