xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#135 closed task (wontfix)

change default zlib compression value

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: minor Milestone: 0.4
Component: core Version: 0.3.x
Keywords: Cc:

Description

Now that we have support for not compressing the pixel part of network packets (see #68), we may well want to reduce the compression to level 1 or 2.

Initial automated test data is inconclusive. because of the latency caused by #132, once that is solved we should be able to get better measurements and properly compare the effect of compression on performance.

Attachments (2)

compress-stats.csv (39.7 KB) - added by Antoine Martin 7 years ago.
trying to measure the effect of compression on performance
x264-compression-1-to-3.csv (3.8 KB) - added by Antoine Martin 7 years ago.
testing compression values 1, 2 and 3 with x264

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Antoine Martin

Attachment: compress-stats.csv added

trying to measure the effect of compression on performance

Changed 7 years ago by Antoine Martin

Attachment: x264-compression-1-to-3.csv added

testing compression values 1, 2 and 3 with x264

comment:1 Changed 7 years ago by Antoine Martin

Resolution: wontfix
Status: newclosed

The test data is inconclusive, leaving this as-is.

Note: See TracTickets for help on using tickets.