xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1355 closed defect (fixed)

osx 1.0 r14397 client seems to be missing dyld library

Reported by: alas Owned by: alas
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description

Trying to launch the 1.0 r14397 client downloaded from your beta directory, I'm seeing the following error - and launch fails.

Schadenfreude:MacOS Schadenfreude$ ./xpra attach tcp:[blah-blah] --opengl=on
2016-11-11 14:45:37,310 Xpra gtk2 client version 1.0-r14397 32-bit
2016-11-11 14:45:37,310  running on Mac OS X 10.12.1
dyld: Library not loaded: @executable_path/../Resources/lib/libgstreamer-1.0.0.dylib
  Referenced from: /Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-14397/Xpra.app/Contents/Resources/bin/gst-plugin-scanner-1.0
  Reason: image not found

Change History (8)

comment:1 Changed 3 years ago by alas

  • Note, also had issue with r14384 .
  • Don't see the issue with the r14155.
  • With r14342 & r14374 I don't see this issue, but sound fails with:
2016-11-11 15:04:26,458 Error: failed to query sound subsystem:
2016-11-11 15:04:26,458  [Errno 2] No such file or directory
  • With r14202 it looks like the printing is disabled...
2016-11-11 15:22:49,456 Error: printing disabled:
2016-11-11 15:22:49,457  Generator expression must be parenthesized if not sole argument (pycups_printing.py, line 405)

Not sure if any of that will help narrow the issue down... looks like the sound and printing issues aren't manifesting with the later clients - but since it won't start I can't be sure.

comment:2 Changed 3 years ago by Antoine Martin

Status: newassigned

Most of these problems are caused by my failed attempts to make an appstore package (#1340).

comment:3 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas
Status: assignednew
  • the "Generator expression must be parenthesized if not sole argument" error was fixed in r14205
  • there were a number of updates to the sound tool paths: r14223 (likely culprit), r14224 + r14226, r14384
  • the "dyld: Library not loaded" should be fixed in r14407 (I'm not 100% certain of this because I don't see the problem on my build system - why, I'm not sure. I can get the error by running one of the "gst-*" binaries, but not when running xpra itself: this should make the sound subprocess fail only, not the main process)
Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 3 years ago by alas

Owner: changed from alas to Antoine Martin

Checked with 1.0 r14416 osx client, still no dyld.

Schadenfreude:MacOS Schadenfreude$ ./xpra attach tcp:[blah blah] --opengl=on -d refresh
2016-11-15 16:21:05,343 Xpra gtk2 client version 1.0-r14416 32-bit
2016-11-15 16:21:05,343  running on Mac OS X 10.12.1
dyld: Library not loaded: @executable_path/../Resources/lib/libgstreamer-1.0.0.dylib
  Referenced from: /Users/Schadenfreude/Desktop/xpra-catalog/xpra-ant-1-14416/Xpra.app/Contents/Resources/bin/gst-plugin-scanner-1.0
  Reason: image not found

comment:5 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

Please make sure that the machine is "clean" and that you've removed previous versions before installing / using this one.
Is this the DMG or PKG? I cannot reproduce with either one..
Is this problem specific to this machine? Or maybe to Mac OS X 10.12.x?

If this bug still occurs, please post:

ls -la /path/to/Xpra.app/Contents/Resources/
ls -la /path/to/Xpra.app/Contents/Resources/bin

Also, you seem to be running "./xpra" from somewhere, knowing where would help.
Is it the one in "MacOS" or the one in "Helper"? Or something else?
I always run directly from where I start the terminal: [/complete/path/to]/Xpra.app/Contents/MacOS/Xpra, the code should always be able to figure out the rest from there.

comment:6 Changed 3 years ago by alas

Owner: changed from alas to Antoine Martin

Rather than properly install the .dmgs, I create folders for them and install in the folders... then I cd into the folder/Xpra.app/Contents/MacOS ... and then run ./xpra from there.

I am still seeing this issue with a newly updated 10.12.x (x=1)... but when I tried with a 10.10.5 it worked as expected. (That's what I get for updating a mac...)

So, I ran the above ... but I expect the content will look like expected. If I weren't able to run the 1.0 r14155 with my weird "shove 'em into a folder" setup, I'd think that was the issue. As it is, not sure what to think.

On 10.12.1:

Schadenfreude:Contents Schadenfreude$ ls -la Resources/
total 864
drwxr-xr-x@  11 Schadenfreude  staff     374 Nov 15 08:58 .
drwxr-xr-x@   9 Schadenfreude  staff     306 Nov 15 08:58 ..
drwxr-xr-x@   3 Schadenfreude  staff     102 Nov 15 08:58 LaunchAgents
drwxr-xr-x@  31 Schadenfreude  staff    1054 Nov 15 08:58 bin
drwxr-xr-x@   5 Schadenfreude  staff     170 Nov 15 08:58 etc
drwxr-xr-x@   3 Schadenfreude  staff     102 Nov 15 08:56 include
drwxr-xr-x@ 185 Schadenfreude  staff    6290 Nov 15 08:58 lib
drwxr-xr-x@  11 Schadenfreude  staff     374 Nov 15 08:58 share
-rw-r--r--@   1 Schadenfreude  staff    3231 Sep 23 23:42 site.pyc
drwxr-xr-x@   9 Schadenfreude  staff     306 Nov 15 08:56 www
-rw-r--r--@   1 Schadenfreude  staff  434275 Nov 15 08:58 xpra.icns
Schadenfreude:Contents Schadenfreude$ ls -la Resources/bin/
total 1432
drwxr-xr-x@ 31 Schadenfreude  staff   1054 Nov 15 08:58 .
drwxr-xr-x@ 11 Schadenfreude  staff    374 Nov 15 08:58 ..
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Bug Report
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Config info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Encoding info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Feature info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 GStreamer info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 GTK info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Keyboard Tool
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Keymap info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Launcher
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Manual
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 NativeGUI info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Network info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 OpenGL check
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Path info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 PowerMonitor
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Print
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Shadow
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Version info
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Webcam Test
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Websockify
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 Xpra
-rwxr-xr-x@  1 Schadenfreude  staff  54956 Nov 15 08:56 gst-inspect-0.10
-rwxr-xr-x@  1 Schadenfreude  staff  55584 Nov 15 08:57 gst-inspect-1.0
-rwxr-xr-x@  1 Schadenfreude  staff  48972 Nov 15 08:57 gst-launch-0.10
-rwxr-xr-x@  1 Schadenfreude  staff  44824 Nov 15 08:58 gst-launch-1.0
-rwxr-xr-x@  1 Schadenfreude  staff  25300 Nov 15 08:57 gst-plugin-scanner-0.10
-rwxr-xr-x@  1 Schadenfreude  staff  21200 Nov 15 08:58 gst-plugin-scanner-1.0
-rwxr-xr-x@  1 Schadenfreude  staff  16920 Nov 15 08:58 python
-rwxr-xr-x@  1 Schadenfreude  staff  17960 Aug 16 03:17 sshpass

On 10.10.5:

TestBotMkV:Contents maint$ ls -la Resources/

total 864

drwxr-xr-x@  11 maint  staff     374 Nov 15 08:58 .
drwxr-xr-x@   9 maint  staff     306 Nov 15 08:58 ..
drwxr-xr-x@   3 maint  staff     102 Nov 15 08:58 LaunchAgents
drwxr-xr-x@  31 maint  staff    1054 Nov 15 08:58 bin
drwxr-xr-x@   5 maint  staff     170 Nov 15 08:58 etc
drwxr-xr-x@   3 maint  staff     102 Nov 15 08:56 include
drwxr-xr-x@ 185 maint  staff    6290 Nov 15 08:58 lib
drwxr-xr-x@  11 maint  staff     374 Nov 15 08:58 share
-rw-r--r--@   1 maint  staff    3231 Sep 23 23:42 site.pyc
drwxr-xr-x@   9 maint  staff     306 Nov 15 08:56 www
-rw-r--r--@   1 maint  staff  434275 Nov 15 08:58 xpra.icns
TestBotMkV:Contents maint$ ls -la Resources/bin/
total 1432
drwxr-xr-x@ 31 maint  staff   1054 Nov 15 08:58 .
drwxr-xr-x@ 11 maint  staff    374 Nov 15 08:58 ..
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Bug Report
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Config info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Encoding info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Feature info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 GStreamer info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 GTK info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Keyboard Tool
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Keymap info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Launcher
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Manual
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 NativeGUI info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Network info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 OpenGL check
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Path info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 PowerMonitor
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Print
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Shadow
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Version info
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Webcam Test
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Websockify
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 Xpra
-rwxr-xr-x@  1 maint  staff  54956 Nov 15 08:56 gst-inspect-0.10
-rwxr-xr-x@  1 maint  staff  55584 Nov 15 08:57 gst-inspect-1.0
-rwxr-xr-x@  1 maint  staff  48972 Nov 15 08:57 gst-launch-0.10
-rwxr-xr-x@  1 maint  staff  44824 Nov 15 08:58 gst-launch-1.0
-rwxr-xr-x@  1 maint  staff  25300 Nov 15 08:57 gst-plugin-scanner-0.10
-rwxr-xr-x@  1 maint  staff  21200 Nov 15 08:58 gst-plugin-scanner-1.0
-rwxr-xr-x@  1 maint  staff  16920 Nov 15 08:58 python
-rwxr-xr-x@  1 maint  staff  17960 Aug 16 03:17 sshpass

comment:7 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

I couldn't test this because it doesn't fail on my test systems but I should have at least verified that the new symlink was present (it was not - sorry), r14452 uses the long-winded way of doing things - which macosx seems to understand better.
New beta uploaded.

Note: the recommended way to install, especially for newer versions of osx with their "challenging" security settings is to use the PKG, which will be signed, at least for the proper release versions - but not for most of the beta builds. See #1340

comment:8 Changed 3 years ago by alas

Resolution: fixed
Status: newclosed

Tested both the 1.0 r14467 .dmg and .pkg against a 1.0 r14449 fedora 23 server.

Both worked painlessly with this 10.12.1 OSX machine.

Closing.

Note: See TracTickets for help on using tickets.