xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1363 closed defect (invalid)

OpenGL and other rendering errors

Reported by: aashidham Owned by: aashidham
Priority: major Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

I've invoked the Xpra server as follows:

xpra start :5455 --bind-tcp=0.0.0.0:5555 --sharing=yes --speaker=yes --html=on --no-daemon

When I run a graphical process inside the Xpra client, I get the following errors (the graphics loads in the browser, but it works poorly and slowly):

user@host: DISPLAY=:5455 ./script.sh
X Error: BadValue (integer parameter out of range for operation) 2
  Extension:    151 (Uknown extension)
  Minor opcode: 3 (Unknown request)
  Resource id:  0x0
X Error: BadValue (integer parameter out of range for operation) 2
  Extension:    151 (Uknown extension)
  Minor opcode: 3 (Unknown request)
  Resource id:  0x0
QGLTempContext: Unable to create GL context.
X Error: BadValue (integer parameter out of range for operation) 2
  Extension:    151 (Uknown extension)
  Minor opcode: 3 (Unknown request)
  Resource id:  0x0
QGLTempContext: Unable to create GL context.
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv2_server_method

I think the GL errors make up a large part of the rendering problem. I've added the following flags to the Xvfb invocation (inside xpra/scripts/config.py on line 69) so the final invocation looks like the following:

['Xvfb-for-Xpra-:5455', '+extension', 'Composite', '+extension', 'GLX', '+extension', 'RANDR', '+extension', 'RENDER', '-screen', '0', '5760x2560x24+32', '-nolisten', 'tcp', '-noreset', '-auth', '/home/ubuntu/.Xauthority', ':5455']

I've also installed python-gtkglext1 as well as python-opengl Ubuntu Linux packages in an attempt to get the QGLTempContext to go away, but no such luck.

Change History (4)

comment:1 Changed 3 years ago by aashidham

Priority: majorcritical

comment:2 Changed 3 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to aashidham
Priority: criticalmajor

If you want to run opengl applications in xpra, see wiki/Usage/OpenGL.

Installing python-gtkglext1 and python-opengl is only needed for client-side opengl accelerated rendering: wiki/ClientRendering/OpenGL.

It looks like your application (whatever it is), is having problems running against Xvfb. You may have better luck running with wiki/Xdummy - though that's often problematic to setup on Ubuntu.

comment:3 Changed 3 years ago by aashidham

What are some red flags about setting up XDummy on Ubuntu?

Also how can I force Xpra to use XDummy instead of Xvfb? Is there a flag I can set?

comment:4 Changed 3 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

See the wiki, which I have already linked to: wiki/Xdummy.
And if you have problems with xdummy, file a separate ticket for that.
BTW, never modify the xpra source directly when you have an "xvfb=" option for this purpose in your xpra config files.

I am closing this ticket as notabug because xpra is working as intended, and the opengl issues are already well documented.

Note: See TracTickets for help on using tickets.