xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1371 closed defect (fixed)

Unable to exit start-desktop server with xpra stop

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 1.0
Component: server Version: trunk
Keywords: Cc:

Description

We aren't handling start-desktop desktop servers (need better terminology for this - I vote "virtual desktop") properly with regards to exiting. Running xpra stop :DISPLAY on a virtual desktop server fails to do anything - nothing in the server logs indicate it gets a connection at all, and the terminal will hang for a few seconds until it times out, then exits.

I am able to exit the server with a SIG-INT if I run with --no-daemon.

The server I am running on is a Fedora 24 trunk r14479 server, and the client is a Fedora 24 trunk r14479 client. I was also doing some testing on a Windows 8.1 client, but the issue is server side.


Other than that, the virtual desktop (or whatever we choose to call it) functionality works quite nicely, and I can see quite a few useful use cases.


Not sure what log flags you want, but let me know and I'll get them to you.

Change History (2)

comment:1 Changed 4 years ago by Antoine Martin

Milestone: 1.0
Owner: changed from Antoine Martin to J. Max Mena

need better terminology for this - I vote "virtual desktop")


I disagree, this is a "start" command, adding "virtual" doesn't really clarify anything as all the "start" commands are using virtual displays (windows or desktops).
Remember that the xpra subcommands are verbs not nouns. ie: "list", "attach", etc..
ie: especially when running a remote command like xpra virtual-desktop ssh:SOMEHOST, this would not be as clear as saying "start-desktop" (or "attach").


I cannot reproduce:

$ xpra start-desktop :100 --start=xterm
Entering daemon mode; any further errors will be reported to:
  /run/user/1000/xpra/:100.log
$ xpra list
Found the following xpra sessions:
/run/user/1000/xpra:
	LIVE session at :100
(..)
$ xpra stop :100
server requested disconnect: server shutdown
xpra at :100 has exited.

Using just xpra stop also works if you only have one session running.

Tested on Fedora 23, 24 and 25. No problem on any of them.
Maybe your installation is broken? Try cleaning everything before reinstalling.

If that does not help, please provide more detailed steps with the "-d all" debug logs, as well as the full package list and python package file lists.

For reference, the original tickets are here: #1247 #1206

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 4 years ago by J. Max Mena

Resolution: fixed
Status: newclosed

Did a thorough turfing and rebuild from latest r14493 source - that seemed to fix it. Must've been a one-time thing. Closing.

Note: See TracTickets for help on using tickets.