xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1397 closed defect (fixed)

Regression: cannot minimise windows displayed by xpra

Reported by: Alfred Owned by: Alfred
Priority: minor Milestone: 2.0
Component: platforms Version: 1.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Description:
Clicking the minimise-window button on any window displayed by xpra does not minimise the window. Instead, the window appears to minimise for a few milliseconds and then returns to its original size. The problem occurs every time.The other window-buttons (maximise, close) work as expected.

Steps to reproduce:
First get xpra to display a window, eg,

xpra start :10 && DISPLAY=:10 xterm & xpra attach :10

Then click on the xterm's minimise-window button.

Software affected: (client and server on the same machine)
No changes were made to the stock configuration of xpra or the operating system. The issue can be reproduced using a fresh install of xpra and the operating system in a virtual machine.

  • xpra versions affected: 1.0-r14532-1
  • xpra versions _not_ affected: 0.15.10-1

Operating systems affected: Ubuntu 14.04 and 16.04.

Window managers affected:

-> xfwm4 (in the xubuntu-desktop package)
-> compiz (in the gnome-session-flashback package in ubuntu 14.04)
-> I have _not_ tried the 'unity' desktop, because my hardware is too old.

Hardware affected:
The problem occurs not only in a virtual machine (kvm) but also on real hardware (intel core2 with gma x3100 integrated graphics)

Attachments (3)

ServerLog.txt (2.7 KB) - added by Alfred 4 years ago.
server log with --debug=state
Server_Info.txt (59.7 KB) - added by Alfred 4 years ago.
System.txt (12.2 KB) - added by Alfred 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Alfred

Attachment: ServerLog.txt added

server log with --debug=state

Changed 4 years ago by Alfred

Attachment: Server_Info.txt added

Changed 4 years ago by Alfred

Attachment: System.txt added

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Milestone: 2.0
Status: newassigned

comment:2 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to Alfred
Status: assignednew

FYI: you should be using this form to start child commands:

xpra start :10 --start=xterm

This is fixed in r14708. (applied to v1.0.x branch in r14709)
Please close if that works for you.

comment:3 Changed 4 years ago by Alfred

Resolution: fixed
Status: newclosed

r14709 works perfectly. Thank you!

Note: See TracTickets for help on using tickets.