xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1407 closed defect (fixed)

--ssh not working with new releases

Reported by: adarrab Owned by: adarrab
Priority: minor Milestone:
Component: client Version: 1.0.x
Keywords: Windows attach ssh custom Cc:

Description (last modified by Antoine Martin)

Hi,

I use "--ssh" which used to work perfectly in old releases e.g.

This is working fine:

D:\Xpra\0.17.4\xpra.exe  attach ssh:SERVER123:100 --ssh="plink -4 -i '%USERPROFILE%\.ssh\viz.ppk' %USERNAME%@SERVER123"  

While this is not:

D:\Xpra\1.0.1-r14710\xpra.exe  attach ssh:SERVER123:100 --ssh="plink -4 -i '%USERPROFILE%\.ssh\viz.ppk' %USERNAME%@SERVER123"

Nothing happens in the second case .. plink starts quickly then disappears. I captured the argument in both cases using wmic:
0.17.4 (working):

plink -4 -i D:\Users\USERNAME\.ssh\viz.ppk USERNAME@SERVER123 -T SERVER123 "xpra initenv;~/.xpra/run-xpra _proxy :100 || $XDG_RUNTIME_DIR/xpra/run-xpra _proxy :100 || xpra _proxy :100",3464

1.0.1-r14710 (not working)

plink -4 -i D:\Users\USERNAME\.ssh\viz.ppk USERNAME@SERVER123 -T SERVER123 "xpra initenv || echo \"Warning: xpra server does not support initenv\" 1>&2;~/.xpra/run-xpra _proxy :100",9784

Server is running on RHEL 6.6 (xpra v0.15.5)

Thank you,

Attachments (1)

_100.log (128.2 KB) - added by adarrab 3 years ago.
xpra v1.0.1-r14723 debug on RHEL 6.6

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by adarrab

Attachment: _100.log added

xpra v1.0.1-r14723 debug on RHEL 6.6

comment:1 Changed 3 years ago by adarrab

I tried to use the latest server xpra v1.0.1-r14723, but it fails on RHEL 6.6. debug log is attached.

Thank you,

comment:2 Changed 3 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to adarrab

Your server log shows a bug which has already been fixed in 1.0.1-r14734, please update your server first.

Please also specify which type of shell is set for your user.

Your command output looks wrong too, it doesn't match the version you claim to have used: the string "Warning: xpra server does not support initenv" has been removed from the client source code for almost a year. It is not present in 1.0

Does it make any difference if you use password authentication instead of the public key? (it would make it easier for me to reproduce the same settings)

comment:3 Changed 3 years ago by adarrab

Thank you Antoine,

Confirmed, 1.0.1-r14734 is working on my server. Though the client with -ssh still doesn't work (windows7 1.0.1-r14723)

The default shell is csh. Login doesn't produce any std out/err (no unusual sources or changes in paths)

This is now the plink command I'm capturing with wmic

plink -4 -i D:\Users\USERNAME\.ssh\viz.ppk USERNAME@SERVER123 -T SERVER123 "sh -c 'xpra initenv;~/.xpra/run-xpra _proxy :100 || $XDG_RUNTIME_DIR/xpra/run-xpra _proxy :100 || xpra _proxy :100'",12580

As for authentication, -pw is fine for debugging, which doesn't work either for me for r14723, while works fine with 0.17.4. So, doesn't make any difference.

Best regards,

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 3 years ago by Antoine Martin

Does it help if you add "--remote-xpra=~/.xpra/run-xpra" to your client command line?
It could be related to csh, can you try temporarily switching to bash as login shell?

comment:5 in reply to:  4 Changed 3 years ago by adarrab

Replying to Antoine Martin:

Does it help if you add "--remote-xpra=~/.xpra/run-xpra" to your client command line?
It could be related to csh, can you try temporarily switching to bash as login shell?

Adding --remote-xpra=~/.xpra/run-xpra doesn't help.

Changing to bash, well nothing worked (0.17.4 or 1.0.1-r14723)

I changed to putty plink and even that works fine with client 0.17.4

D:\Xpra\0.17.4\xpra.exe  attach ssh:SERVER02:10 --ssh="D:\\putty\\plink -4 -pw PASSWORD %USERNAME%@SERVER02" --remote-xpra=~/.xpra/run-xpra

This doesn't

D:\Xpra\1.0.1-r14723\xpra.exe  attach ssh:SERVER02:10 --ssh="D:\\putty\\plink -4 -pw PASSWORD %USERNAME%@SERVER02" --remote-xpra=~/.xpra/run-xpra
Last edited 3 years ago by adarrab (previous) (diff)

comment:6 Changed 3 years ago by Antoine Martin

Owner: changed from adarrab to Antoine Martin
Status: newassigned

This is caused by #1000, specifically this changeset: r13622.

comment:7 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to adarrab
Status: assignednew

Added a putty workaround in r14779, applied to v1.0.x branch in r14780.

There is a beta 1.0.2 build for windows with this fix here: http://xpra.org/beta/windows/.

I've also added an environment variable to make it easier to debug putty / ssh command line problems: set XPRA_SSH_DEBUG=1 to print the exact ssh command line used for connecting to the server. (applied to all branches)

@adarrab: please close if this works for you.

comment:8 Changed 3 years ago by adarrab

Resolution: fixed
Status: newclosed

Confirmed! it is working in 1.0.2-r14780
many thanks,

Note: See TracTickets for help on using tickets.