xpra icon
Bug tracker and wiki

Opened 8 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#1453 closed defect (fixed)

gedit menus don't respond to clicks with macos client, centos 6.x server

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 2.0
Component: client Version: trunk
Keywords: osx Cc:

Description

Other combinations work fine:

  • Fedora servers
  • centos 7.x servers
  • windows or Linux clients

Could well be related to: #469, #770, #761

Change History (2)

comment:1 Changed 8 weeks ago by Antoine Martin

Status: newassigned

Found that this is a regression by trying the old 0.14.x LTS as server. Bisection:

So the problem is XPRA_REPARENT_ROOT which was changed to enabled by default in r13690.
More details in #770, now re-opened.

So r15216 disables it again in the v1.0.x branch (v2.0 has not been changed so far because it doesn't support centos6), which means that drag and drop will not work in the next update... we have to choose one or the other.

comment:2 Changed 7 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

r15262 is a better fix: we undo a hackish change so that we can keep reparent-to-root (and therefore drag-n-drop support). 15263 for v1.x branch.
Will follow up in #469.

Last edited 7 weeks ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.