xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

#1459 closed defect (fixed)

Systray icons unresponsive

Reported by: alin104n Owned by: alin104n
Priority: major Milestone:
Component: client Version: 1.0.x
Keywords: Cc:

Description

Forwarded systray icons are unresponsive to mouse actions. I'm running Xfce on Arch Linux and installed xpra using the xpra-winswitch 1.0.3-1 AUR package.
This doesn't happen in an older version (0.17.4).

Attachments (3)

arch-not-working-xpra-client-1.0.3-tray.log (13.4 KB) - added by na-- 3 weeks ago.
arch-working-xpra-client-0.17.6-tray.log (26.6 KB) - added by na-- 3 weeks ago.
fedora24-working-xpra-client-1.0-tray.log (25.8 KB) - added by na-- 3 weeks ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to alin104n

@alin104n: which application are you testing with?
Can you try with vlc? Does that work?
If not, can you attach the "-d tray" log to this ticket?

comment:2 Changed 3 weeks ago by na--

Cc: nedyalko.andreev+xpra@… added

I have the exact same issue. When using the Xpra 1.0.3 client on Arch linux to connect to an Arch linux server (also with Xpra 1.0.3), the server system tray icons are shown but unresponsive. Application windows work normally, but left or right mouse clicks on systray icons have no effect. The specific applications do not seem to matter, all of them that I've tried do not work, including just VLC without anything else in the session.

When I downgrade the client to version 0.17.6, the systray icons of the very same server session become responsive. It may be just an Arch linux client bug, because everything is fine with a Xpra 1.0 client on Fedora 24 and I remember having the same problems with Xpra 1.0 or 1.0.1 on Arch.

I will attach logs with "-d tray" for the above 3 cases. The server is Arch linux, running just VLC in a Xpra 1.0.3 session. The clients are xpra 1.0.3 on arch (*not working*), xpra 0.17.6 on arch (working) and xpra 1.0 on fedora 24 (working)

comment:3 Changed 3 weeks ago by na--

Cc: nedyalko.andreev+xpra@… removed

Changed 3 weeks ago by na--

Changed 3 weeks ago by na--

comment:4 Changed 3 weeks ago by Antoine Martin

Can you please try to grab "xpra info" from the server with each version?
(we want to see where the window representing the tray is mapped on the server side)

comment:5 Changed 3 weeks ago by Antoine Martin

Just looking at the logs, the working version (0.17.x) has lots of log events like this one:

ClientTray(1).reconfigure(False) geometry=(2136, 1404, 32, 32)

But with 1.0:

ClientTray(1).reconfigure(False) geometry=None

Looking at the list of changes in the 2 critical classes:

The following changeset stands out immediately: r14591.
And I messed it up... sorry.
r15247 fixes that, already included in the 1.x branch as of r15249.

comment:6 Changed 3 weeks ago by na--

Resolution: fixed
Status: newclosed

No worries and thanks for the lightning fast fix! :)

I can confirm that your changes fixed the problem. Using the "xpra-winswitch-svn" package from the Arch AUR (with changed PKGBUILD so that it will use the v1.0.x branch and r15249) works like a charm!

Note: See TracTickets for help on using tickets.