xpra icon
Bug tracker and wiki

Opened 3 months ago

Last modified 2 months ago

#1466 new defect

Xpra systray icons have black background.

Reported by: alin104n Owned by: alin104n
Priority: major Milestone:
Component: client Version: 1.0.x
Keywords: Cc:

Description

I'm using last version of xpra in Arch Linux and I get random black backgrounds for the forwarded systray icons. This happens usually only to some icons, when a new icon appears or right from the start of the client. I'm unable to figure out a pattern here.

Change History (4)

comment:1 Changed 2 months ago by Antoine Martin

Owner: changed from Antoine Martin to alin104n

Please specify what exact version you have. (unlikely to be trunk)
What desktop environment, what command lines, what example applications we can use to reproduce, etc.
See wiki/ReportingBugs

comment:2 Changed 2 months ago by alin104n

Version: trunk1.0.x

Version: xpra v1.0.4-r15266
DE: Xfce

I see black background for Pidgin, Blink, Deluge, Thunderbird with Firetray extension.

comment:3 Changed 2 months ago by alin104n

This problem doesn't seem to be occurring in the 2.x version anymore.

Last edited 2 months ago by alin104n (previous) (diff)

comment:4 Changed 2 months ago by Antoine Martin

There are no differences between 1.x and 2.x when it comes to the systray code on Linux (there were changes for MS Windows clients only).
So the "fix" is unlikely to have come from xpra, maybe another of your system libraries got updated?

Note: See TracTickets for help on using tickets.