xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

#1478 closed defect (fixed)

Windows Version x64 errno 10057 when using ssl

Reported by: B Owned by: B
Priority: blocker Milestone: 2.1
Component: client Version: trunk
Keywords: Cc:

Description

Hi,

when using http://xpra.org/beta/windows/Xpra-x86_64_Setup_2.1-r15472.exe in ssl mode to attach to a xpra server, i will get the

Errorno 10057: A request to send or receive data was disallowed because the socket is not connected and (when sending on datagram socket using a sendto call) no address was supplied

Server: ubuntu xenial, 64bit, nvidia graphic
Client: Win7 64bit sp1, i guess latest patch level

Greets

Change History (4)

comment:1 Changed 4 months ago by B

tcp works fine, ssh i didnt test

comment:2 Changed 4 months ago by Antoine Martin

Milestone: 2.1
Priority: majorblocker
Status: newassigned
Summary: Windows Version x64 errornr 10057 when using sslWindows Version x64 errno 10057 when using ssl

This only seems to affect the 2.x builds made with MSYS2 (#678).
Looks like this python bug: SSL handshake fails after TCP connection in getpeername() but unfortunately the fixes are for Python 3.x only, and they aren't linked from the ticket.
Also, the workaround given (calling getpeername) doesn't seem to work here.

comment:3 Changed 4 months ago by Antoine Martin

Owner: changed from Antoine Martin to B
Status: assignednew

Fix for trunk in r15473, r15474 for older branches.

Uploaded 32-bit and 64-bit beta (EXE) builds: http://xpra.org/beta/windows/

@B: please close if this works for you.

comment:4 Changed 4 months ago by B

Resolution: fixed
Status: newclosed

works for me, great, thanks!

Note: See TracTickets for help on using tickets.