xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#1487 closed defect (fixed)

HTML client. Languages support

Reported by: Denis01 Owned by: Denis01
Priority: critical Milestone: 2.2
Component: html5 Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

Hello.
after some test it is worth of opening a new ticket.
Several platforms: W7, W8, W10
Several browsers: IE, Chrome, Opera, Firefox (copyboard works perfectly in Chrome! so advice your users Chrome for both direction text coping)
Several languages RU, FR, DE

The problem is to display as
FR: è, ç, é
DE: ö, ß, ü
RU: п, ю, д (all Cyrillic symbols in fact)
Remarks:
1) in xpra windows client everything works in those 3 languages
2) html client does react on language change in browser! so then in tray EN - the keyboard starts from QWERTY... if you switch into FR it starts from AZERTY. That is absolutely correct!

Some screens might give the ideas how to fix:
1) IE identifies the language (other browsers -not. but it is not bothering at all)

2) Zone 3- we are in RUssian, Zone 2 - this text displayed by server(so codepage should be OK), zone 1 seems to be displayed by XPRA server

3) let's tyМpe smth in RU (zone 3=RU), Zone 2 - latin symbols of keys pressed on the keyboard (not Russian ones). and that's strange that in Zone 1 we can see strange symbols. normally that happens than codepage of application does not understand the codes of letters used.

And in this zone in this case we should see smth like "this page being edited" in Russian


4) I ve tried to copy some text in RU from Win Notepad into XPRA html client.
"Привет" and "Меня зовут" (Zone1) and we can see that html client converted it in strange codes....

hope that it will help ....
SOS! Html client can't be used for now....
Denis

Attachments (4)

img1.jpg (83.2 KB) - added by Denis01 3 weeks ago.
img2.jpg (106.0 KB) - added by Denis01 3 weeks ago.
img3.jpg (114.5 KB) - added by Denis01 3 weeks ago.
img4.jpg (81.4 KB) - added by Denis01 3 weeks ago.

Download all attachments as: .zip

Change History (14)

Changed 3 weeks ago by Denis01

Attachment: img1.jpg added

Changed 3 weeks ago by Denis01

Attachment: img2.jpg added

Changed 3 weeks ago by Denis01

Attachment: img3.jpg added

Changed 3 weeks ago by Denis01

Attachment: img4.jpg added

comment:1 Changed 3 weeks ago by Denis01

Priority: majorcritical

comment:2 Changed 3 weeks ago by Antoine Martin

Description: modified (diff)
Milestone: 2.2
Owner: changed from Antoine Martin to Denis01

As usual, please specify the exact version you are running. See wiki/ReportingBugs.

copyboard works perfectly in Chrome! so advice your users Chrome for both direction text coping

It should work in all browsers, so that would need to be added to #1461

1) IE identifies the language (other browsers -not. but it is not bothering at all)

The latest code should be able to identify the locale with all browsers, try http://xpra.org/beta.builds or build from source.

2) Zones 3..

I assume you talk about image no 3 since there is no zone 3 marked anywhere.
Anyway, the window title is displayed by the browser, and that was easy to fix: try r15498.

Mapping unicode characters to the keysym string that the server expects was much harder: done in r15503. (r15502 was also needed to ensure we don't lose the keyboard layout set in the UI)
This should allow you to type in any character that has a keysym in the file I have used to generate the map.
If this works for you, please re-assign this ticket to "afarr" - as this change is likely to cause regressions somewhere.

I ve tried to copy some text in RU from Win Notepad into XPRA html client.
"Привет" and "Меня зовут" (Zone1) and we can see that html client converted it in strange codes....

This should go in a different ticket, maybe #1461.

comment:3 Changed 3 weeks ago by Denis01

Thanks a lot!
Could you please publish r15498, r15502 and r15503 in the beta repository (in Centos 7.3 don't see them) to test them quickly.

Last edited 3 weeks ago by Antoine Martin (previous) (diff)

comment:4 Changed 3 weeks ago by Antoine Martin

You don't need a new RPM build to test since all these changes are confined to the HTML5 client. You can install the latest trunk HTML5 client like this:

svn co https://xpra.org/svn/Xpra/trunk/src/html5
sudo rsync -rp ./html5/* /usr/share/xpra/www/

comment:5 Changed 3 weeks ago by Antoine Martin

There are new beta builds for centos 7.x now.

comment:6 Changed 3 weeks ago by Denis01

Resolution: fixed
Status: newclosed

Antoine, that is simply magic!
It works!
But changing keyboard on-fly craches the system.
1) RU->EN= Ok the system accepts the symbols and displays them corrctly
but 2) EN->RU =KO. it seems that each symbol system undersnads like a key-combination ctrt-F, cnrt-C etc and tries to save the document, open another one (in case of openoffice).But it is object of other ticket - change keyboard on-fly
And clipboard does not work

comment:7 Changed 3 weeks ago by Denis01

Antoine,
Crashed the test server and had to reinstall.
Could you please advice how properly (by which commands)can install the beta builds.....
<ashamed>

comment:8 Changed 3 weeks ago by Antoine Martin

Could you please advice how properly (by which commands)can install the beta builds.....

http://winswitch.org/downloads/rpm-repository.html?dist_select=CentOSBeta

comment:9 Changed 3 weeks ago by Denis01

Tried that but
Yum install xpra

http://winswitch.org/beta/CentosOS/6/x86_64/repodata/repomd.xml: Error 22 - 404 file not found

There is a repomd.xml in /centos/7/repodata/

Last edited 3 weeks ago by Antoine Martin (previous) (diff)

comment:10 Changed 3 weeks ago by Antoine Martin

centos 6 is not supported in version 2 onwards, see: wiki/Platforms.
In comment:3 you said you were using centos 7.3

Note: See TracTickets for help on using tickets.