xpra icon
Bug tracker and wiki

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#1522 closed defect (fixed)

window client side decorations problems

Reported by: Denis01 Owned by: Denis01
Priority: major Milestone:
Component: html5 Version: trunk
Keywords: Cc:

Description

Hello,
faced some problems with the beta version 2.1-r15785 64-bit (centos7.3, HTML client)
In the attached files the application look in 2.0.2-r15657 64-bit version (2_0_2_version.jpg) and in 2.1-r15785 (2_1_version.jpg).
So in 2.1 there is no "band" above application (marked with string) but in 2.0.2 there is band. So picking the application on this band by mouse pointer in 2.0.2 version i can easily move and resize the application window but in 2.1 version application sceen either frozen or jumping in unpredicted way.
What it could be? Could you help!

On other hand (probably it is another situation and just for information as it could be normal way of working) tried to avoid this problem installed Proxy server 2.1-r15785 beta and Target server with application behind with 2.0.2-r15657. And Proxy of higher version can't connect to Target server with lower version.
The error:

2017-05-21 12:35:28,587 DotXpra(/var/run/user/1000/xpra, ['/var/run/user/1000/xpra'] - 1000:1000 - 111).socket_path(:proxy-2578)=/var/run/user/1000/xpra/localhost.localdomain-proxy-2578
2017-05-21 12:35:28,587 create_control_socket: socket path='/var/run/user/1000/xpra/localhost.localdomain-proxy-2578', uid=1000, gid=1000, state=DEAD
2017-05-21 12:35:28,587 Warning: failed to create socket directory '/var/run/user/1000/xpra'
2017-05-21 12:35:28,587  [Errno 2] No such file or directory: '/var/run/user/1000/xpra'
2017-05-21 12:35:28,587 create_unix_domain_socket failed for '/var/run/user/1000/xpra/localhost.localdomain-proxy-2578'
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/proxy/proxy_instance_process.py", line 273, in create_control_socket
    sock, self.control_socket_cleanup = create_unix_domain_socket(sockpath, None, 0o600)
  File "/usr/lib64/python2.7/site-packages/xpra/scripts/server.py", line 376, in create_unix_domain_socket
    listener.bind(sockpath)
  File "/usr/lib64/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 2] No such file or directory
2017-05-21 12:35:28,612 Error: failed to setup control socket '/var/run/user/1000/xpra/localhost.localdomain-proxy-2578':
2017-05-21 12:35:28,612  [Errno 2] No such file or directory

Attachments (2)

2_0_2_version.jpg (43.6 KB) - added by Denis01 19 months ago.
2_1_version.jpg (49.3 KB) - added by Denis01 19 months ago.

Download all attachments as: .zip

Change History (14)

Changed 19 months ago by Denis01

Attachment: 2_0_2_version.jpg added

Changed 19 months ago by Denis01

Attachment: 2_1_version.jpg added

comment:1 Changed 19 months ago by Denis01

So to make it simple - without this "band" (in 2.1 beta) just can't use the application. Screen is jumping, can't click on buttons...

comment:2 Changed 19 months ago by Denis01

Morning!
Tested with some other applications.
Quite the same situation in case of 2.1 version without "band" (or bar i dont't know how to call it correctly) above the application)
Some applications work, others - no.
For those which don't work: sometimes can pull/move normally the sceeen inside the browser but generally buttons dont't work(no reaction upon the click on the buttons).

Last edited 19 months ago by Denis01 (previous) (diff)

comment:3 Changed 19 months ago by Denis01

Component: androidhtml5

comment:4 Changed 19 months ago by Antoine Martin

Owner: changed from Antoine Martin to Denis01
Summary: Some issues with beta versionwindow client side decorations problems

What you call "band" is known as the "window title bar".
2.1 improved support for window attributes set by the applications, including the ability for applications to request the window to not be decorated (removing the title bar): see #1491 for details.

From the screenshot, it looks like the application is drawing its own title bar (aka "client side decorations") and therefore it makes sense for us to not draw another one on top. It looks like this is working as expected.

Using the proxy should not make any difference at all here.

If however, the window does not behave as expected, for example if it is difficult to trigger a move or resize, then that means we're not handling the application requests properly.
In which case, please specify the browser used and an application I can use to reproduce the problem.

The create_unix_domain_socket failed is completely unrelated and does not belong in this ticket.

comment:5 Changed 19 months ago by Denis01

Hello,
Thanks for the detailed explanations!
Browser Chrome 53.0.2785
And the application - the distrubutives are about 0,5 Gb. How can i pass them? Or i can set up a test server to connect and check the situation directly on it.

comment:6 Changed 19 months ago by Antoine Martin

Please find an open-source application that reproduces the problem.
I need the source, and I need to be able to run locally to debug.
This test application works more or less correctly: test_window_initiatemoveresize

comment:7 Changed 19 months ago by Denis01

Ok, will try to find smth.
But would it be possible (for a time being, awating me searching) to have some setting in 2.1 version with activation and disactivation. Like "window decoration" = ON/OFF? As it could appear with one or another application because of various reasons...

comment:8 Changed 19 months ago by Antoine Martin

have some setting in 2.1 version with activation and disactivation

I don't have time for this, but I will take a patch if you submit one.

Last edited 19 months ago by Antoine Martin (previous) (diff)

comment:9 Changed 19 months ago by Denis01

Hello,
have a look on #1491 - won't be an easy task for me :-) but will do the best.
Seems that in:

have the modifications for the "decoration" settings.
But even if the version Centos7.3 2.1-r15785 is installed don't see (for example)

if ("title" in metadata) {

in Window.js file and not

if ("decorations" in metadata) {

as described in r15517
So probably the version is not completely assembled.
Could you please publish new beta release with all the modifs just to be sure everything is in newest version.
P.S. And for a while i am keeping the fingers crossed - the newest version of files might resolve the problem....

comment:10 Changed 19 months ago by Denis01

Apologize for stupid remark in "comment:9"
seems that have found everything

Last edited 19 months ago by Denis01 (previous) (diff)

comment:11 Changed 19 months ago by Denis01

Think this ticket should be closed.
Will create new one for evolution.
Settings to choose decoration type and assign to myself - will prepare the script

comment:12 Changed 19 months ago by Denis01

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.