xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1547 closed defect (duplicate)

Connection closes

Reported by: DocMAX Owned by: Antoine Martin
Priority: major Milestone: 2.1
Component: network Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

xpra proxy :14500 --daemon=no --bind-tcp=0.0.0.0:14500 \
   --tcp-auth= --ssl-cert=/etc/xpra/ssl-cert.pem \
   --bind=auto --auth=none --socket-dirs=/var/run/xpra \
   --socket-permissions=666 --log-dir=/var/log --pidfile=/var/run/xpra.pid
Jun 13 19:44:08 htpc xpra[10314]: 2017-06-13 19:44:08,505 Error: error in network packet write/format
Jun 13 19:44:08 htpc xpra[10314]: 2017-06-13 19:44:08,505  cannot concatenate 'str' and 'tuple' objects
Jun 13 19:44:08 htpc xpra[10314]: Traceback (most recent call last):
Jun 13 19:44:08 htpc xpra[10314]:   File "/usr/lib/python2.7/site-packages/xpra/net/protocol.py", line 292, in _write_format_thread_loop
Jun 13 19:44:08 htpc xpra[10314]:     self._add_packet_to_queue(*gpc())
Jun 13 19:44:08 htpc xpra[10314]:   File "/usr/lib/python2.7/site-packages/xpra/net/protocol.py", line 308, in _add_packet_to_queue
Jun 13 19:44:08 htpc xpra[10314]:     self._add_chunks_to_queue(chunks, start_send_cb, end_send_cb)
Jun 13 19:44:08 htpc xpra[10314]:   File "/usr/lib/python2.7/site-packages/xpra/net/protocol.py", line 346, in _add_chunks_to_queue
Jun 13 19:44:08 htpc xpra[10314]:     header_and_data = pack_header(proto_flags, level, index, payload_size) + data
Jun 13 19:44:08 htpc xpra[10314]: TypeError: cannot concatenate 'str' and 'tuple' objects
Jun 13 19:44:08 htpc xpra[10314]: 2017-06-13 19:44:08,508 stop(client connection lost, Protocol(None))

Change History (2)

comment:1 Changed 3 years ago by Antoine Martin

Component: androidnetwork
Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #1517

comment:2 Changed 3 years ago by Antoine Martin

Milestone: 2.22.1

(edit milestone)

Note: See TracTickets for help on using tickets.