xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 4 months ago

#1565 closed defect (wontfix)

twm in desktop mode crashes the server

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: minor Milestone: 2.1
Component: server Version: trunk
Keywords: x11 Cc:

Description (last modified by Antoine Martin)

trying to move a window or using the twm menu results in a complete deadlock.

killing xpra does not help, the X11 server is hosed and no longer responds.

Looks like an upstream bug.

Change History (4)

comment:1 Changed 5 months ago by Antoine Martin

Description: modified (diff)
Status: newassigned

comment:2 Changed 5 months ago by Antoine Martin

Priority: criticalminor

Not an xpra bug - lowering priority, this can be reproduced with just dummy + twm:

/usr/libexec/Xorg -noreset -novtswitch -nolisten tcp -config /etc/xpra/xorg.conf :10
#verify we can access the display:
DISPLAY=:10 xprop -root
DISPLAY=:10 xterm&
DISPLAY=:10 twm&
#now click on the title bar of the xterm:
DISPLAY=:10 xdotool mousemove 90 10 mousedown 1
#and now the X11 server is inaccessible:
DISPLAY=:10 xprop -root

comment:3 Changed 5 months ago by Antoine Martin

Reported upstream: twm deadlocks the server

comment:4 Changed 4 months ago by Antoine Martin

Resolution: wontfix
Status: assignedclosed

As I was kindly reminded: in this response, this is not a bug - twm grabs the server, and nothing ever gets a chance to emit the click release event that would cause twm to release the grab.

The only solution that I can think of at this point is to use virtual input devices (uinput, etc - #173) instead of xtest.

Note: See TracTickets for help on using tickets.