xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 3 weeks ago

#1585 closed defect (invalid)

xpra cannot use lz4 with python-lz4 0.10.x

Reported by: Aynur Shakirov Owned by: Aynur Shakirov
Priority: major Milestone: 2.1
Component: encodings Version: trunk
Keywords: lz4, compressor Cc:

Description

Hello all.

xpra version 16413

I updated the python-lz4 package up to 0.10.1 version in Arch Linux. Unfortunately, xpra cannot use the lz4 compression with this version of lz4 python bindings.

xpra info:

[root@kumomech ~]# xpra info | grep compre

Warning: running as root
network.compressors=('zlib', 'lzo')

Change History (2)

comment:1 Changed 4 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to Aynur Shakirov

Please specify what branch of xpra you're using. 2.0.x?

The fix for the lz4 version lookup has been applied months ago: r15836 (r15840 for older branches).

For more error information, you can also try to run:

XPRA_NETWORK_DEBUG=1 /usr/lib/python2.7/site-packages/xpra/net/compression.py
Last edited 4 weeks ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 weeks ago by Antoine Martin

Resolution: invalid
Status: newclosed

Closing: I assume that the issue is in the arch packaging and not xpra.

Note: See TracTickets for help on using tickets.