xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

#1601 closed defect (fixed)

Clipboard sync broken

Reported by: chaanakya Owned by: Antoine Martin
Priority: major Milestone: 2.2
Component: clipboard Version: 2.1.x
Keywords: Cc:

Description

I upgraded xpra yesterday from the previous version on the official xpra repository for Debian Stretch. Yesterday (and before that), clipboard syncronization worked perfectly well. However, after yesterday's update, clipboard sync is broken. When I select some text to be copied from the main X server, I verify that it has indeed been copied into the primary clipboard buffer using xclip -o -selection primary . I then try to paste it in a Xpra window (e.g. firefox), which results in nothing being pasted. Looking at the log, I get client 1: Warning: sanitizing NULL gtk selection data to avoid crash . I am running xpra version 2.1-r16505.

Change History (2)

comment:1 Changed 3 months ago by Antoine Martin

Status: newassigned

Sounds like the fix for #1579 may be catching cases where the data is still valid.

comment:2 Changed 3 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Well, that's very odd: the crash from #1579 doesn't happen any more and it was very easy to reproduce previously, but the clipboard does fail instead...
So r16524 disables this workaround code in older branches, and I'm re-spinning 2.1-2 packages with this change only. (MS Windows and Mac OS were not affected)

@chaanakya: this should fix the problem, works for me.

Will follow up in #1579.

Note: See TracTickets for help on using tickets.