xpra icon
Bug tracker and wiki

Opened 3 weeks ago

Closed 2 weeks ago

#1602 closed defect (fixed)

Wrong shell after --start-child=urxvt

Reported by: Philip D Loewen Owned by: Antoine Martin
Priority: minor Milestone: 2.2
Component: server Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

I launch xpra with "--start-child=urxvt". As of the last major update, this starts a urxvt instance in which the shell is provided by "sh" instead of "bash". The expected behaviour is to launch "bash", and this actually happened until very recently. I don't know enough to guess why it changed.

Here urxvt is a popular terminal emulator, v9.21, released 2014-12-31.

My username in /etc/passwd does give /bin/bash as my default shell.

Both client and server are the same box, running Ubuntu 16.04.2 LTS with xpra version 2.1 revision r16525.

Some internet searches suggest that the environment variable $SHELL may be relevant. When urxvt opens with /bin/sh, that variable is undefined.

Thanks a lot for this fine software.

Change History (2)

comment:1 Changed 3 weeks ago by Antoine Martin

Description: modified (diff)
Status: newassigned

That's probably caused by #1105. Works fine here on Fedora.. maybe Ubuntu isn't populating the environment variables through the pam login.

Problem is that we can't blindly forward all the environment variables to the system-wide proxy process which runs as root, as that would be insecure.
For example, $SHELL could be abused as it may be used by commands executed as root.

comment:2 Changed 2 weeks ago by Antoine Martin

Description: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in r16613, this will be included in the next stable update.

Thanks for the bug report!

Note: See TracTickets for help on using tickets.