Xpra: Ticket #1630: Failed to create socket and run html server

2017-08-31 10:19:06,579 created unix domain socket: /home/sheenam/.xpra/Server-10^[[0m
^[[33m2017-08-31 10:19:06,579 Warning: failed to create socket directory '/var/run/xpra'^[[0m
^[[33m2017-08-31 10:19:06,579  [Errno 13] Permission denied: '/var/run/xpra'^[[0m
^[[33m2017-08-31 10:19:06,579 Warning: cannot create socket '/var/run/xpra/Server-10'^[[0m
^[[33m2017-08-31 10:19:06,579  [Errno 2] No such file or directory^[[0m
^[[33m2017-08-31 10:19:06,579  /var/run/xpra does not exist^[[0m
^[[33m2017-08-31 10:19:06,579  user 'sheenam' is a member of groups: adm, cdrom, sudo, dip, plugdev, lpadmin, sambashare, xpra^[[0m
/bin/sh: 1: dbus-launch: not found
dbus-launch failed to start using command 'dbus-launch --close-stderr':
 exit code is 127
^[[33m2017-08-31 10:19:06,609 Warning: menu forwarding is disabled:^[[0m
^[[33m2017-08-31 10:19:06,609  cannot load dbus helper: org.freedesktop.DBus.Error.Spawn.ExecFailed: //bin/dbus-launch terminated abnormally without any error message^[$
^[[33m2017-08-31 10:19:06,736 Warning: libvpx ABI version 5 is too old:^[[0m
^[[33m2017-08-31 10:19:06,736  disabling YUV444P support with VP9^[[0m
^[[33m2017-08-31 10:19:06,778 Warning: no X11 RandR support on :10^[[0m
^[[31m2017-08-31 10:19:07,231 Error: cannot import websockify connection handler:^[[0m
^[[31m2017-08-31 10:19:07,231  cannot import name WebSocketRequestHandler^[[0m
^[[31m2017-08-31 10:19:07,231  the html server will not be available^[[0m
^[[33m2017-08-31 10:19:07,310 Warning: webcam forwarding is disabled^[[0m
^[[33m2017-08-31 10:19:07,311  the virtual video directory '/sys/devices/virtual/video4linux' was not found^[[0m
^[[33m2017-08-31 10:19:07,311  make sure that the 'v4l2loopback' kernel module is installed and loaded^[[0m
2017-08-31 10:19:07,311 found 0 virtual video devices for webcam forwarding^[[0m
2017-08-31 10:19:07,318 pulseaudio server started with pid 1985^[[0m
/bin/sh: 1: pulseaudio: not found
Warning: failed to import GStreamer:
 GStreamer 1.0: Namespace Gst not available
 GStreamer 0.10: No module named pygst
^[[31m2017-08-31 10:19:07,559 Error: failed to query sound subsystem:^[[0m
^[[31m2017-08-31 10:19:07,559  query did not return any data^[[0m
^[[33m2017-08-31 10:19:07,562 Warning: failed to load or register our dbus notifications forwarder:^[[0m
^[[33m2017-08-31 10:19:07,562  org.freedesktop.DBus.Error.Spawn.ExecFailed: //bin/dbus-launch terminated abnormally without any error message^[[0m
^[[33m2017-08-31 10:19:07,562  if you do not have a dedicated dbus session for this xpra instance,^[[0m
^[[33m2017-08-31 10:19:07,562  use the 'notifications=no' option^[[0m
^[[33m2017-08-31 10:19:07,563 Warning: cannot load dbus helper:^[[0m
^[[33m2017-08-31 10:19:07,563  org.freedesktop.DBus.Error.Spawn.ExecFailed: //bin/dbus-launch terminated abnormally without any error message^[[0m
^[[31m2017-08-31 10:19:07,567 dbus server error

Thu, 31 Aug 2017 02:42:04 GMT - sheenam: summary changed

xpra v1.0.7-r16697 There is no xpra in /var/run .. I am not sure what is the problem. Please help

Thu, 31 Aug 2017 04:25:21 GMT - Antoine Martin: owner, description changed

Please see wiki/ReportingBugs and provide the details required.

Thu, 31 Aug 2017 06:20:18 GMT - sheenam:

Operating System: Ubuntu 14.04 (No Desktop) virtual machine running on windows 8 host xpra config: I attached file name xpraconfig.txt Commands used: xpra start --bind-tcp= --html=on --start-child=wireshark xpra info : I attached file name xpra_info.txt software installed from : https://xpra.org/dists/trusty/main/binary-amd64/ Xpra version: xpra v1.0.7-r16697 Log file : file attached with name 0.log

I am trying to open wireshark app with browser using : localhost:10000 and on windows 8 host : ip:10000 but I can't open wireshark with browser in both. I tried using xterm as well but even I can't access xterm using browser.

Thu, 31 Aug 2017 06:29:21 GMT - sheenam: attachment set

  1. xpra showconfig file

Thu, 31 Aug 2017 06:29:50 GMT - sheenam: attachment set

  1. Log file

Thu, 31 Aug 2017 06:32:24 GMT - sheenam: attachment set

  1. xpra info(command output)

Thu, 31 Aug 2017 06:32:42 GMT - Antoine Martin: status changed; resolution set

The error is right there in your log output:

Error: cannot import websockify connection handler:
 cannot import name WebSocketRequestHandler
 the html server will not be available

The version of websockify in Ubuntu Trusty is too old: http server on Ubuntu Trusty.

Thu, 31 Aug 2017 06:46:27 GMT - sheenam:

Ohh I thought so but can you please help me with how to install it from git? I tried apt-get but it is unable to locate setuptools and pip as well.

I used "git clone https://github.com/novnc/websockify" and have websockify directory. Please tell me what commands to use now to install ?

I am new to Linux sorry for this question.

Thank you so much

Thu, 31 Aug 2017 09:07:11 GMT - Antoine Martin:


(you may also be able to use python-pip)

Sat, 23 Jan 2021 05:29:34 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1630