xpra icon
Bug tracker and wiki

#1643 closed defect (fixed)

application taskbar icons changed to defaults

Reported by: Thomas Esposito Owned by: Antoine Martin
Priority: major Milestone: 2.2
Component: client Version: 2.1.x
Keywords: Cc:

Description

I am running the 2.1 client on Windows 10 and the 1.0.6 server on RHEL6.6.

Normally, each X application has an application-specific icon displayed on the Windows 10 taskbar. If I toggle the xpra client OpenGL option on/off, or if I return from the Windows 10 lock screen, the application-specific icons are replaced by a generic xpra icon.

I get the proper icons back if I disconnect and reconnect.

Change History (2)

comment:1 Changed 20 months ago by Antoine Martin

Status: newassigned

Shouldn't be too hard to fix.

comment:2 Changed 20 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Bug confirmed, was caused by the window reinit code used in r10573 for opengl.
Fixed in r16866 + r16868 + r16869.

You can find 2.2 beta builds with this fix here: https://xpra.org/beta/windows/.

Note: See TracTickets for help on using tickets.