xpra icon
Bug tracker and wiki

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#1648 closed defect (invalid)

Debian Sid python2.7 breaks xpra

Reported by: cpw Owned by: Antoine Martin
Priority: major Milestone: 2.2
Component: packaging Version: 2.1.x
Keywords: debian Cc:

Description

Hello
Debian Sid has updated python2.7 and broken a lot of python packages including xpra. Downgrading to 2.7.13-2 works to fix it, but latest sid is 2.7.14 and is verifiably broken.

Lots of bugs, including a couple mentioning xpra.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=874272
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=873921
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875317

I believe you need to rebuild with the newer python somehow?
I didn't see an issue here for this problem so figured you might appreciate the heads up.

Attachments (1)

bugdata.zip (1.7 MB) - added by cpw 8 months ago.
output of bug tool

Download all attachments as: .zip

Change History (3)

Changed 8 months ago by cpw

Attachment: bugdata.zip added

output of bug tool

comment:1 Changed 8 months ago by Antoine Martin

Resolution: invalid
Status: newclosed

There are no sid packages supported here, this is a Debian downstream bug.

comment:2 Changed 8 months ago by cpw

Fair enough. I suspect it'll still be a problem when this migrates to buster, judging by the responses in the bug report (they're just marking the new version of python as breaking the "broken" packages).

Note: See TracTickets for help on using tickets.