xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 4 years ago

Last modified 18 months ago

#166 closed defect (wontfix)

Switching keyboard layouts does not work as expected

Reported by: angel.tsankov Owned by: angel.tsankov
Priority: major Milestone: future
Component: core Version: 0.3.2
Keywords: Cc:

Description

Multiple keyboard layouts are setup on both xpra server host and on xpra client host. On both hosts the key sequence to switch between keyboard layouts is LSHIFT + RSHIFT. Pressing this key combination on xpra client switches the keyboard layout on the client, but the input characters sent to the attached application are still those of the previous keyboard layout.

Change History (8)

comment:1 Changed 6 years ago by Antoine Martin

Status: newaccepted

Does it help if you disconnect and re-connect?

How are those keyboards configured? What software does the switching? etc..
Need more info.

comment:2 Changed 6 years ago by angel.tsankov

No, re-connecting does not help.

I do not understand what is meant by "How are those keyboards configures?".

The software that does the switching is configured via GNOME's Keyboard Preferences (Main Menu -> System -> Preferences -> Keyboard).

I tried un-checking "Separate layout for each window". Upon next pressing of LSHIFT+RSHIFT, everything was fine. Then I pressed LSHIFT+RSHIFT again and the sane problem appeared again: the keyboard layout indicator in the notification area shows that another layout is in effect, but the input characters are still from the previous layout.

comment:3 Changed 6 years ago by Antoine Martin

Milestone: 0.4future

Will probably require Xkb support, see #86

comment:4 Changed 5 years ago by Antoine Martin

Status: acceptednew

Hmmm, what we would need to do is to trigger the layout change server-side at the same time as the client does it.
The problem is that I don't think that the switch key combination is exposed to us, so the server has no way of knowing about it.

Please post some of the debug information from wiki/Keyboard, maybe there is something in there we can use (setxkbmap -print ?).
I suspect that this is a gnome/input-methods thing though, in which case we would need to find a way to listen for such switching events. (if at all possible).

comment:5 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to angel.tsankov

comment:6 Changed 4 years ago by Antoine Martin

Resolution: wontfix
Status: newclosed

Not heard back, closing. See also #86

comment:7 Changed 4 years ago by Antoine Martin

Note: v0.14 includes a keyboard layout switcher from the tray, this may help you override the current setting.
There is also a new input-methods switch, which you may want to try.

comment:8 Changed 18 months ago by Antoine Martin

See also #1380.

Note: See TracTickets for help on using tickets.