xpra icon
Bug tracker and wiki

Opened 9 days ago

Closed 9 days ago

#1683 closed defect (wontfix)

audio dependency issues with centos7 packages

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 2.2
Component: packaging Version: trunk
Keywords: Cc:

Description

This ticket records what was done to ensure centos7 packages can be upgraded to 2.2 and the compromises made.

When we split client and server builds (#1253) the new "xpra" metapackage brought in as a dependency all the packages so that users upgrading would get the exact same result in terms of functionality.

Ideally we would like the "python2-xpra-audio" package to not install unless it is going to work, but the dependencies required for that are not available in centos7 as there are no python-gstreamer packages. Also no "ugly" plugins, but those are optional anyway.
This would result in xpra being stuck on the 2.1 packages as yum would refuse to upgrade python2-xpra-audio to a version with broken dependencies.

Change History (1)

comment:1 Changed 9 days ago by Antoine Martin

Resolution: wontfix
Status: newclosed

The spec file refactoring in r17388 had brought in those dependencies again, r17394 fixes that.

That's all, centos7 users who want to use audio forwarding will need to somehow install a python-gstreamer package based on the gi bindings for gstreamer1.

Note: See TracTickets for help on using tickets.