xpra icon
Bug tracker and wiki

Opened 9 months ago

Closed 9 months ago

#1736 closed defect (fixed)

Traceback in Session Info

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: major Milestone:
Component: client Version: 2.2.x
Keywords: Cc:

Description

Client and server are both Fedora 26 machines running 2.X trunk r17951

After opening the Session Info window, the following traceback is printed (after about a second):

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/gtk_base/session_info.py", line 646, in populate_tab
    if not self.populate_cb():
  File "/usr/lib64/python2.7/site-packages/xpra/client/gtk_base/session_info.py", line 1056, in populate_graphs
    pixel_scale, in_pixels = values_to_scaled_values(tuple(self.pixel_in_data)[3:N_SAMPLES+4], min_scaled_value=100)
  File "/usr/lib64/python2.7/site-packages/xpra/simple_stats.py", line 55, in values_to_scaled_values
    data.insert(0, None)
AttributeError: 'tuple' object has no attribute 'insert'

After which, the charts no longer work.

Change History (1)

comment:1 Changed 9 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r17952, was caused by r17519.

Note: See TracTickets for help on using tickets.