xpra icon
Bug tracker and wiki

Opened 7 months ago

Closed 7 months ago

#1745 closed defect (fixed)

Unable to start TCP servers

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: critical Milestone: 2.3
Component: server Version: trunk
Keywords: Cc:

Description

My server is a Fedora 26 machine running trunk r18033 - and I am unable to start a TCP server with --bind-tcp=0.0.0.0:2200. -d network prints the following traceback and error:

2018-01-17 09:38:08,755 get_enabled_encoders(['rencode', 'bencode', 'yaml']) enabled=['yaml', 'rencode', 'bencode']
2018-01-17 09:38:08,757 setting up SSL sockets: 
2018-01-17 09:38:08,757 setting up https / wss (secure websockets): 
2018-01-17 09:38:08,757 setting up TCP sockets: ('0.0.0.0', 2200)
2018-01-17 09:38:08,758 create_tcp_socket('0.0.0.0', 2200)
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/socket_util.py", line 139, in setup_tcp_socket
    tcp_socket = create_tcp_socket(host, iport)
  File "/usr/lib64/python2.7/site-packages/xpra/server/socket_util.py", line 132, in create_tcp_socket
    log("%s.bind(%s)", listener, sockaddr)
UnboundLocalError: local variable 'log' referenced before assignment
xpra initialization error:
 failed to setup tcp socket on 0.0.0.0:2200 local variable 'log' referenced before assignment

Change History (2)

comment:1 Changed 7 months ago by J. Max Mena

Quick bisection narrows down r18032 to be the cause. I suspect it's because you do not initialize the logger in create_tcp_socket.

comment:2 Changed 7 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r18034

Note: See TracTickets for help on using tickets.