xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#1755 closed defect (wontfix)

uinput pseudo devices are failing on Ubuntu 16.04.

Reported by: Kundan Owned by: Antoine Martin
Priority: major Milestone:
Component: server Version: 2.2.x
Keywords: Cc:

Description

On Ubuntu 16.04, uinput devices are not getting created and xpra is failing with a message saying.

Warning: cannot use uinput
2018-01-29 20:09:56,152  '-config' argument not found in the xvfb command

It is then using Xtest as a fallback.

The command used for starting xpra.

xpra start :10 --bind-tcp=127.0.0.1:1030 --webcam=/dev/video1 --env=XDG_RUNTIME_DIR=/tmp/10 --input-devices=xi

My xpra version is:-
xpra v2.2.3-r18043

Attachments (1)

xpra_uinput_fail.log (5.5 KB) - added by Kundan 4 months ago.
xpra output log showing uinput failing.

Download all attachments as: .zip

Change History (3)

Changed 4 months ago by Kundan

Attachment: xpra_uinput_fail.log added

xpra output log showing uinput failing.

comment:1 Changed 4 months ago by Antoine Martin

Resolution: wontfix
Status: newclosed

Ubuntu 16.04 uses Xvfb and uinput requires Xdummy, see wiki/Xdummy for more details. For uinput, see #173.

I'm afraid we're not going to fix this. Ubuntu will just stop messing with the xorg setup and permissions, hopefully.

comment:2 Changed 4 months ago by Kundan

On the client side while attaching with:-

xpra attach tcp:127.0.0.1:1030 --microphone=on

I am getting following messages.

2018-01-29 20:33:55,283 Xpra gtk2 client version 2.2.3-r18043 64-bit
2018-01-29 20:33:55,284  running on Linux Ubuntu 16.04 xenial
2018-01-29 20:33:56,846 GStreamer version 1.8.3 for Python 2.7.12 64-bit
2018-01-29 20:33:57,236 OpenGL_accelerate module loaded
2018-01-29 20:33:57,236 Error loading OpenGL support:
2018-01-29 20:33:57,237  __init__() takes at least 2 positional arguments (1 given)
2018-01-29 20:33:57,268  keyboard settings: rules=evdev, model=pc105, layout=us
2018-01-29 20:33:57,270  desktop size is 1366x768 with 1 screen:
2018-01-29 20:33:57,270   :0.0 (361x203 mm - DPI: 96x96) workarea: 1366x695 at 0x24
2018-01-29 20:33:57,271     monitor 1 (309x173 mm - DPI: 112x112)
2018-01-29 20:33:57,328 Warning: invalid frame extents value '[0, 0, 0, 0, 0, 0, 28, 0]'
2018-01-29 20:33:57,328  this is probably a bug in 'Compiz'
2018-01-29 20:33:57,328  using '[0, 0, 28, 0]' instead
2018-01-29 20:33:58,245 enabled fast mmap transfers using 256MB shared memory area
2018-01-29 20:33:58,246 Xpra X11 server version 2.2.3-r18043 64-bit
2018-01-29 20:33:58,246  running on Linux Ubuntu 16.04 xenial
2018-01-29 20:33:58,246 enabled remote logging
2018-01-29 20:33:58,264 Warning: cannot start microphone forwarding:
2018-01-29 20:33:58,265  user and server environment are identical,
2018-01-29 20:33:58,267  this would create a sound loop
2018-01-29 20:33:58,269  use XPRA_ALLOW_SOUND_LOOP=1 to force enable it
2018-01-29 20:33:58,272 Attached to 127.0.0.1:1030 via tcp
2018-01-29 20:33:58,272  (press Control-C to detach)

2018-01-29 20:33:58,290 server does not support xi input devices
2018-01-29 20:33:58,291  server uses: xtest
2018-01-29 20:33:59,697 sound output Warning: found 2 audio input devices:
2018-01-29 20:33:59,698 sound output  * Built-in Audio
2018-01-29 20:33:59,698 sound output    alsa_card.pci-0000_00_03.0
2018-01-29 20:33:59,698 sound output  * Built-in Audio Analog Stereo
2018-01-29 20:33:59,698 sound output    alsa_output.pci-0000_00_1b.0.analog-stereo
2018-01-29 20:33:59,698 sound output  to select a specific one,
2018-01-29 20:33:59,699 sound output  use the environment variable 'XPRA_PULSE_SINK_DEVICE_NAME'
2018-01-29 20:33:59,699 sound output using default pulseaudio device
2018-01-29 20:34:00,222 sound output using audio codec opus
Note: See TracTickets for help on using tickets.