xpra icon
Bug tracker and wiki

#1760 closed defect (fixed)

AttributeError on latest client

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: critical Milestone: 2.3
Component: client Version: trunk
Keywords: Cc:

Description

Running a beta r18246 client against a beta r18246 server - both Fedora 26 and built from source.

I'm able to connect, but immediately upon connection the client outputs the following traceback and exits:

2018-02-01 12:08:40,357 error on <class 'xpra.platform.xposix.gui.ClientExtras'> cleanup
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/ui_client_base.py", line 642, in cleanup
    x.cleanup()
  File "/usr/lib64/python2.7/site-packages/xpra/platform/xposix/gui.py", line 733, in cleanup
    if self.session_bus:
AttributeError: 'ClientExtras' object has no attribute 'session_bus'
2018-02-01 12:08:40,888 error on <class 'xpra.platform.xposix.gui.ClientExtras'> cleanup
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/ui_client_base.py", line 642, in cleanup
    x.cleanup()
  File "/usr/lib64/python2.7/site-packages/xpra/platform/xposix/gui.py", line 733, in cleanup
    if self.session_bus:
AttributeError: 'ClientExtras' object has no attribute 'session_bus'

Change History (2)

comment:1 Changed 10 months ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

This particular traceback only occurs during cleanup (when the process terminates), not on connection.

It is caused by r18241 which disables part of r18240, it is fixed in r18247 - or by re-enabling the (broken) screensaver detection with XPRA_DBUS_SCREENSAVER=1 (see ticket:540#comment:20)

If your client disconnects immediately, then that's a different problem.
Note: there seems to be some clipboard related problems caused by #1312, if that causes problems then just run with the clipboard disabled until that is solved.

comment:2 Changed 10 months ago by J. Max Mena

Resolution: fixed
Status: newclosed

Weird - I rebuilt my server and client with r18247 and everything works as expected even running with clipboard enabled.

Closing.

Note: See TracTickets for help on using tickets.